https on hostname not working

hmaddy

Well-Known Member
May 6, 2020
268
30
28
Chennai
cPanel Access Level
Root Administrator
https or ssl on hostname not working. As per the inspection certificates are valid for 10 more months. But still its not valid in browser.
 

Attachments

ffeingol

Well-Known Member
PartnerNOC
Nov 9, 2001
723
285
363
cPanel Access Level
DataCenter Provider
The screen you posted shows that the root certificate is not trusted. Is that a cPanel generated certificate or have you installed your own?
 

ffeingol

Well-Known Member
PartnerNOC
Nov 9, 2001
723
285
363
cPanel Access Level
DataCenter Provider
Yea, I'd be interested in how you got LE on the hostname, as that's not something that cPanel/WHM does out of the box as far as I know.
 

hmaddy

Well-Known Member
May 6, 2020
268
30
28
Chennai
cPanel Access Level
Root Administrator
Install Self-Signed Certificate to Hostname.

1) Login to WHM as a root user.

2) Go to “Service Configuration”.


3) Then select the following services and click on “Browse Certificate”.

Calendar, cPanel, WebDisk, Webmail, and WHM Services

Dovecot Mail Server

Exim (SMTP) Server

FTP Server


4) Select hostname and click on “Use Certificates”.

5) Then click on “Install”.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
11,032
1,741
363
cPanel Access Level
Root Administrator
Thanks for the additional details. If you are pulling the SSL from another domain, it may not properly secure the hostname of the machine.

If you try replacing this with a cPanel-signed SSL certificate instead, does that work properly? You can force that process to happen with this command:

Code:
/usr/local/cpanel/bin/checkallsslcerts