HTTPS support not compiled in

nixgurus

Member
Feb 16, 2011
18
0
51
Google
cPanel Access Level
Root Administrator
I am trying to install CodeGuard plugin on my cpanel based servers. On 2 of them I am getting following error while using following command,

Code:
wget -O cginstall.sh https://www.codeguard.com/partners/cpanel_plugin?api_key=<YOUR_API_KEY>
After running mentioned command I am getting following error on screen

Code:
[email protected] [~]# wget -O cginstall.sh http://www.codeguard.com/partners/cpanel_plugin?api_key=<YOUR_API_KEY>
--2012-03-27 09:25:14--  http://www.codeguard.com/partners/cpanel_plugin?api_key=<YOUR_API_KEY>
Resolving www.codeguard.com (www.codeguard.com)... 184.72.219.90
Connecting to www.codeguard.com (www.codeguard.com)|184.72.219.90|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.codeguard.com/partners/cpanel_plugin?api_key=<YOUR_API_KEY> [following]
https://www.codeguard.com/partners/cpanel_plugin?api_key=<YOUR_API_KEY>: HTTPS support not compiled in.
How I can resolve this issue ?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello :)

You will need to ensure that "wget" on your system is compiled with SSL support.

Thank you.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello,

Couldn't you use curl to get these files?

Code:
curl --O cginstall.sh http://www.codeguard.com/partners/cpanel_plugin?api_key=<YOUR_API_KEY>
This should work. curl should always have https support as far as I'm aware. There are also a slew of reasons (cited at curl vs Wget) for using curl over wget.

Otherwise, you could try removing and reinstalling wget if it was installed via rpm:

Code:
rpm -qa | grep -i wget
rpm -e --nodeps wget
yum install wget
You'll likely have to comment out the exclude line in /etc/yum.conf file to install wget after removing it, then uncomment it again after that.

Thanks!
 

nixgurus

Member
Feb 16, 2011
18
0
51
Google
cPanel Access Level
Root Administrator
Thanks a lot for the help. My issue resolved by reinstalling wget. The problem was that script is going to get a lot of files from wget-ssl only. That's why I have to get wget working.