durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
Hi, http for the new domain works fine... but https gives me

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

The client and server don't support a common SSL protocol version or cipher suite.
both chrome and FF show error.

I am using cloudflare

This is a new server install and i am using the default values in apache global config. I am uisng the default cypher and the default protocol which is TLSv1.2

I know i have seen this issue before but not able to find it. I checked the DNS and its all good.


UPDATE: well i took a stab in the dark and removed the CF orange cloud from my domain and now it works https with no error. Why would that be like that? I have always used the orange cloud on the domain name itself and for all records with http traffic. Any Ideas ?

UPDATE: looks like the issue is that i disabled the free cert that CF gives you so on the crypto page it said expired cert which tells me that it could not match the cypher because there was no cypher to match.

So i enabled the universal SSL on the bottom of that page, then i had it set up at the top of the page to full strict and it said no cert, so i went to full and then it found the cert. Then after a little while i was able to change it back to full strict without any issue.
 
Last edited:
  • Like
Reactions: cPanelLauren

tho6460

Registered
Nov 22, 2018
1
0
1
DaNang
cPanel Access Level
Website Owner
I have the same problem, tried your methods as well as tried to fix ERR_SSL_VERSION_OR_CIPHER_MISMATCH.

on Google. But it still did not work for me.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston
Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!