Huge difference on number of emails between cpanel/roundcube and outlook

mmaciel

Active Member
Mar 25, 2019
31
4
8
Brazil
cPanel Access Level
Root Administrator
Hey guys, so i'm having this problem where cpanel or roundcube shows me this particular email account has 3.18 GB of emails, equal to over 7000 emails on the inbox folder, but when configuring this account on any email manager (outlook, firebird, windows mail, etc) it only shows 1.2 GB, with a little over 2000 emails on the inbox folder. No matter what, it only ever downloads this amount, like the rest doesn't exist.

1612285635614.png

What's happening here? Using the command du -sh on the mail folder, i can see that this email account has 2.6 GB, but i'm using the compress messages option in whm, so i guess this is right.

Appreciate any help.
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,919
608
273
cPanel Access Level
Root Administrator
Hey there! I'm sorry to hear the email isn't working as intended. Since this is happening with multiple mail client tools, it sounds like this could be an issue on the server side of some sort. Could you check the /var/log/maillog while you try and access the mails with your client to see if any errors appear there? That log shows the user connections to the system, so I'm wondering if something is timing out or not working properly.
 

Handssler Lopez

Well-Known Member
Apr 30, 2019
52
18
8
Guatemala
cPanel Access Level
Root Administrator
Did you check if the account has "Deleted Only" mail?

Roundcube by default when "Delete emails" only hides them and they are no longer visible through Roundcube, likewise when the account is configured it does not show or download them.

Check through HORDE and see if there are emails that need to be purged.

I hope I've helped!
 

mmaciel

Active Member
Mar 25, 2019
31
4
8
Brazil
cPanel Access Level
Root Administrator
Hey there! I'm sorry to hear the email isn't working as intended. Since this is happening with multiple mail client tools, it sounds like this could be an issue on the server side of some sort. Could you check the /var/log/maillog while you try and access the mails with your client to see if any errors appear there? That log shows the user connections to the system, so I'm wondering if something is timing out or not working properly.
Hi, thanks for the answer. Nothing unusual shows up on the log, only regular login and logout notifications. And just to clarify, the email is working relatively fine, besides those missing mails, everything works normally, i can send and receive new mails from this account like all the others.


Did you check if the account has "Deleted Only" mail?

Roundcube by default when "Delete emails" only hides them and they are no longer visible through Roundcube, likewise when the account is configured it does not show or download them.

Check through HORDE and see if there are emails that need to be purged.

I hope I've helped!
Hey, thanks for your suggestion, but that was not it either. Thing is, on roundcube/horde, i can see it has over 500 unread mails, but from outlook for instance, it only shows me 300 or so unread mails. So the emails are actually there in the inbox folder, but for some reason, outlook and others email managers can't reach them.

-----------------------------------

A little more info that may be helpful. On outlook, the oldest email is from 12/30/2019, but it should have emails from as old 04/25/2018. They show up on roundcube/horde just fine, not sure why outlook won't download them.
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,919
608
273
cPanel Access Level
Root Administrator
Inside /var/log/maillog there may not be any errors, but there could be a timeout or something else showing up. I did look into this a bit and couldn't find any instances with similar behavior.

You're always welcome to open a ticket and have us check directly on the machine as well.
 

mmaciel

Active Member
Mar 25, 2019
31
4
8
Brazil
cPanel Access Level
Root Administrator
Inside /var/log/maillog there may not be any errors, but there could be a timeout or something else showing up. I did look into this a bit and couldn't find any instances with similar behavior.

You're always welcome to open a ticket and have us check directly on the machine as well.
Alright, i opened a ticket.
#94199100
Thanks.
 

mmaciel

Active Member
Mar 25, 2019
31
4
8
Brazil
cPanel Access Level
Root Administrator
Hey @cPRex

Honestly, i'm not sure the problem was the laptop, because before that, i had tried configuring his email on my own notebook, and had the same problem. The only thing i changed this time around was configuring the email as pop3 instead of imap and everything downloaded. Also, after that, a folder containing synchronization error logs appeared in outlook with over 50 thousand messages. They all pointed to the same error code 800CCC0F-0-0-560, and after googling that error, i came across this thread from microsoft community and apparently that's how you fix it.

Thanks again for your support cPRex.