The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Huge Email Issue

Discussion in 'E-mail Discussions' started by fcomstoc, Jun 6, 2016.

Tags:
  1. fcomstoc

    fcomstoc Registered

    Joined:
    Jun 6, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Las Vegas, NV, USA
    cPanel Access Level:
    Root Administrator
    We have a VPS with WHM and cPanel, everything has been ok except EXIM has taken over the VPS, within a week it runs out of iNodes and space due the the massive amounts of emails we seem to be getting, its all garbage. We do not host email at all on this server, I have to keep EXIM for outgoing from the sites on the server.

    I set all the account's default address to go to :blackhole but I still seem to be getting thousands of emails an hour in the /var/spool/exim/input/ folder.

    This issue has crashed the sever twice, once because it ran out of space and the other because it ran out of iNodes.

    I need to get this resolved ASAP, not sure what to do at this point,

    Thank you.
     
  2. 24x7serversecurity

    Joined:
    Aug 31, 2015
    Messages:
    19
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hey there :),

    It appears that you are getting spam emails. So you can setup Spam Assassin which filters those Spam emails according to their Spam score. You can specify the spam score to lowest number as you do not use this server for Mails. Go through the documentations of Spam Assassin and configure your Exim accordingly.

    Tweak Settings - Mail - Documentation - cPanel Documentation

    Also Login to WHM >> go to Exim Configuration Manager >> search "SpamAssassin"
    and tweak the scores.
     
  3. fcomstoc

    fcomstoc Registered

    Joined:
    Jun 6, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Las Vegas, NV, USA
    cPanel Access Level:
    Root Administrator
    I did as you said, I updated the score from 0 to 10.0 hopefully this helps with the issue, do you know is there any other way to prevent incoming email while still allowing outgoing?

    I checked back about 5 minutes later and there are 78 new emails, so no luck using that one,
     
    #3 fcomstoc, Jun 6, 2016
    Last edited: Jun 6, 2016
  4. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,145
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello :),

    I think you are accounts are sending lot of mail from your server and due to that all mail are stuck in your server mail queue (/var/spool/exim/input) , I will suggest you please check your mail logs and try to find out which account is sending all these mails. And remove all spam mails from your server mail queue so that you will get inode full issue.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page