Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Huge Problem With BIND

Discussion in 'Bind/DNS/Nameserver' started by Drewley, Jul 3, 2007.

  1. Drewley

    Drewley Member

    Joined:
    Oct 30, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    Got my shiny new server this morning... CentOS 5 Ent. i686..

    installed cpanel.. cant access cpanel test page via main ip? :(


    i think i have issues with bind..
    output from a bind restart via WHM:

    Attempting to restart named

    Waiting for named to restart.... . . . . . . . . . . finished.

    named has failed, please contact the sysadmin (result was "named is not running"). Jul 3 13:49:02 darkstar named: zone localdomain/IN: loading master file localdomain.zone: file not found Jul 3 13:49:02 darkstar named: localhost_resolver/localdomain/IN: file not found Jul 3 13:49:02 darkstar named: zone localhost/IN: loading master file localhost.zone: file not found Jul 3 13:49:02 darkstar named: localhost_resolver/localhost/IN: file not found Jul 3 13:49:02 darkstar named: zone 0.0.127.in-addr.arpa/IN: loading master file named.local: file not found Jul 3 13:49:02 darkstar named: localhost_resolver/0.0.127.in-addr.arpa/IN: file not found Jul 3 13:49:02 darkstar named: zone 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loading master file named.ip6.local: file not found Jul 3 13:49:02 darkstar named: localhost_resolver/0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: file not found Jul 3 13:49:02 darkstar named: zone 255.in-addr.arpa/IN: loading master file named.broadcast: file not found Jul 3 13:49:02 darkstar named: localhost_resolver/255.in-addr.arpa/IN: file not found Jul 3 13:49:02 darkstar named: zone 0.in-addr.arpa/IN: loading master file named.zero: file not found Jul 3 13:49:02 darkstar named: localhost_resolver/0.in-addr.arpa/IN: file not found Jul 3 13:49:02 darkstar named: zone darkstar.xtendhosting.co.uk/IN: loaded serial 2007070301 Jul 3 13:49:02 darkstar named: zone ns1.xtendhosting.co.uk/IN: loaded serial 2007070301 Jul 3 13:49:02 darkstar named: zone xtendhosting.co.uk/IN: loaded serial 2007070301


    Any ideas guys?
     
  2. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    166
    First off, ssh in the box.
    Edit the /etc/named.conf

    and comment out the following statements with their functions :

    view "localhost_resolver" ( with what ever follows after it )
    view "internal" ( with what ever follows after it )

    At : view "external"
    comment out the

    match-clients { !localhost; };
    match-destinations { !localhost; };

    so it looks like :

    // match-clients { !localhost; };
    // match-destinations { !localhost; };

    and

    service named restart

    If that doesn`t work :

    /scripts/upcp --force

    If that doesn`t work, try running a
    /scripts/fixnamed
    /scripts/rebuildnamedconf
    /scripts/restartsrv_named
     
  3. Drewley

    Drewley Member

    Joined:
    Oct 30, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    thanks very much for your reply!

    have done your edits;

    service named restart:

    [root@darkstar scripts]# service named restart
    Stopping named: [FAILED]
    Starting named:
    Error in named configuration:
    /etc/named.conf:50: unknown option 'match-clients'
    /etc/named.conf:51: unknown option 'match-destinations'
    /etc/named.conf:52: unknown option 'recursion'

    /scripts/upcp --force: no change

    /scripts/fixnamed: doesnt do anything? just goes to new line?
    /scripts/rebuildnamedconf: same
    /scripts/restartsrv_named: same error as above :s

    looks like i have major problems :(

    by the way im running cpanel 11
     
  4. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    166
    Issue fixed :)
     
  5. Drewley

    Drewley Member

    Joined:
    Oct 30, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    bin_asc sorted it all out for me!!

    thanks so much to him!!

    looks like it was permisson problem with rndc.key?!!

    thanks!!
     
  6. expedio

    expedio Active Member

    Joined:
    Jun 30, 2007
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    56
    You can also try to backup named.conf and then run /scripts/rebuildnamedconf
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    166
    Wouldn`t have worked as he had bind-chroot installed. Removed that, reinstalled simple bind, rebuilt named.conf, removed some lines, everything is aok now :)
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice