Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hundreds of Excessive Resource Usage emails from lfd despite setting low memory

Discussion in 'General Discussion' started by Colm Troy, Jun 27, 2017.

  1. Colm Troy

    Colm Troy Registered

    Joined:
    Jun 27, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Dublin
    cPanel Access Level:
    Root Administrator
    Hi,

    I'm getting hundreds of these daily

    Time: Tue Jun 27 04:40:27 2017 -0400
    Account: xxx
    Resource: Virtual Memory Size
    Exceeded: 508 > 500 (MB)
    Executable: /opt/cpanel/ea-php56/root/usr/bin/php-cgi
    Command Line: /opt/cpanel/ea-php56/root/usr/bin/php-cgi /home/myaccount/public_html/factory/wp-admin/admin-ajax.php
    PID: 4401 (Parent PID:4365)
    Killed: No

    So I understand I can disable these emails. But I'd rather understand the root cause and try and reduce memory usage.

    I've already taken the following steps:

    1.) I've set the PHP.ini memory limit to be 128M
    2.) I've tweaked the Apache global config Max Request Workers to 60

    Server Info
    Knownhost VPS - 2.5GB RAM
    Apache 2.4 - MPM Prefork
    PHP 5.6 suPHP handler

    I should also note that I recently upgraded from an older version of Centos/WHM to the latest version of WHM/Centos and EA4 - and I never had these kinds of issues prior to the upgrade.

    Can anyone advise on:

    1.) Why I'm getting scripts consuming greater than 500mb of memory when the memory limit is set at 128M?
    2.) Are there any tips for reducing my memory footprint for EA4 that I should implement? My machine mainly consists of WordPress installs. I've experimented with PHP-FPM but I had to switch back to suPHP as I was experiencing some bugs with Cpanels fpm implementation not picking up user.ini values and for the brief time I had switched to FPM I didn't see a significant change in RAM usage. I also tried mod_ruid but I heavily rely on mod_security and I was seeing tons of permissions errors when using mod_ruid with mod_security - argh!

    Any advice greatly appreciated.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,766
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    That particular script, may be under an attack of some sort, someone trying to brute force login.
    This thread may be of some use:
    wp-admin/admin-ajax.php causing Suspicious process running - ConfigServer Community Forum

    This 500MB is a setting in CSF, different than memory limits.

    Make sure all your wordpress installs are always up to date, including any addons they may use.
     
  3. Colm Troy

    Colm Troy Registered

    Joined:
    Jun 27, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Dublin
    cPanel Access Level:
    Root Administrator
    Can you explain that a bit more Infopro? If a script is set to only use 128M of RAM, surely it technically shouldn't be possible for it to use 500M?
     
Loading...

Share This Page