The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I Accidently Deleted a lot of DNS Zones from /var/named

Discussion in 'Bind / DNS / Nameserver Issues' started by Dr. Bogger, Nov 6, 2008.

  1. Dr. Bogger

    Dr. Bogger Well-Known Member

    Joined:
    Dec 21, 2003
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    I accidently deleted a bunch of DNS Zone .db files from /var/named... i tried to add them each back one by one, and in whm under "Add a DNS Zone", i get this error: "Sorry, that's an invalid domain"

    Anyone know how i can add the dns zones back in named?
     
  2. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    cpbackup makes a backup of var named if you have backup enabled.
    make sure group named has access to the files db files.
     
  3. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    Even if you deleted the zones from /var/named, the configuration will still have them. You would need to remove the corresponding zones from /etc/named.conf before readding.

    If you have local backups enabled, check

    PATH_TO_BACKUP/cpbackup/daily/daily/dirs/_var_named


    It should have all your zones. If backups have already updated, try weekly and so on.
     
  4. razvantutu

    razvantutu Registered

    Joined:
    Sep 13, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    use /scripts/rebuildnsdzones
     
  5. Dr. Bogger

    Dr. Bogger Well-Known Member

    Joined:
    Dec 21, 2003
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    i tried that, didnt work...
     
  6. apscinsspl

    apscinsspl Well-Known Member

    Joined:
    Mar 15, 2008
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    Delete its entry from /etc/named.conf also and then add it from WHM.

    Else from SSH create a db directly in /var/named

    Either ways should solve the problem
     
Loading...

Share This Page