The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I broke my server ! Wanna cry !

Discussion in 'General Discussion' started by Hines, Jul 21, 2010.

  1. Hines

    Hines Active Member

    Joined:
    Apr 23, 2010
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    PLEASE ASSIST! SSL ruined! Wanna cry !

    Having DNS issues with some people not being able to conenct to my site, I went into WHM and decided to change some security settings.

    I went to : Service Configuration >> Manage Service SSL Certificates

    ...and reset my certificates.

    Now my site is down! :( :( :( :( :( :(

    I can go to the homepage only. Every other link from the menu is broken and it says:

    Not Found
    The requested URL ...was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    I, literally, want to cry.

    Can anyone help?
     
    #1 Hines, Jul 21, 2010
    Last edited: Jul 21, 2010
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Do you mean, your site works, but the menus on it do not? Sounds like a htaccess problem to me. (short URLs?)
     
  3. Hines

    Hines Active Member

    Joined:
    Apr 23, 2010
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Yes. The homepage is visible...and you can see the main menu.

    But every single menu item is broke. When you click on any menu item it takes you back to the error message I quoted.

    The thing is, I didn't modify any files in public_html (like .htaccess).....This all started when I was (foolishly) messing around in WHM.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I've peeked at the link you sent me. You are using short URLs on the site and it would seem to me there's some sort of issue with your .htaccess file in the root directory of that site (public_html)


    Without knowing all that you did before hand, no real way of knowing all that happened, but you might check for an htaccess file and if you find one, open it and check that it contains what it should. (and is not munged somehow)
    Back it up of course before doing anything to it for safe keeping.

    Now rename it from .htaccess to .htaccess.bak or something, for testing.

    I'll assume those menu links will now work, only the actual URL they point to is now longer.

    That should hopefully get the site back up (and help prevent the crying thing) ;)
     
  5. Hines

    Hines Active Member

    Joined:
    Apr 23, 2010
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    It worked ! ! ! ! ! !

    I AM SOOOOOOOO THRILLED! ! ! !

    I never would have guessed that my htaccess file got mangled.

    Are you married? ......because I think I am falling in love with you. :p :D

    Thank you SOOO much for taking the time out of your day to offer your revered advice and help a person in need. You have no idea how much you have helped!!!!

    :D :D :D :D :D :D :D
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes I am married. :p

    Glad I was able to help a bit, anyway.
     
Loading...

Share This Page