The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I cannot log into FileZilla

Discussion in 'General Discussion' started by JMPRockFm, Aug 20, 2016.

Tags:
  1. JMPRockFm

    JMPRockFm Registered

    Joined:
    Aug 20, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hello,

    I cannot log into filezilla the other day I was able to, but for some reason I cannot now?

    I get
    Code:
    Error:    Disconnected: No supported authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)
    Error:    Could not connect to server
    
    What is the reason for this and does anybody know how to fix it thanks
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,734
    Likes Received:
    661
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    It looks like key authentication is failing for SFTP access based on the error message. Are you able to access the server via SSH with the same credentials?

    Thank you.
     
  3. ItsMattSon

    ItsMattSon Well-Known Member

    Joined:
    Sep 5, 2016
    Messages:
    72
    Likes Received:
    16
    Trophy Points:
    8
    Location:
    Perth
    cPanel Access Level:
    Root Administrator
    Hi,

    Just passing through this thread but I've seen this error message before when trying to login as root with a password after disabling root logins via Security Center > SSH Password Authorization Tweak.

    Possibly unrelated (sorry in advance!)
     
  4. ItsMattSon

    ItsMattSon Well-Known Member

    Joined:
    Sep 5, 2016
    Messages:
    72
    Likes Received:
    16
    Trophy Points:
    8
    Location:
    Perth
    cPanel Access Level:
    Root Administrator
    Hi guys,

    I just got this working so might as well share what I did in case it is related.

    I use FileZilla, so I had to change the Protocol dropdown to 'SFTP' and then (because I've disabled password auth and I have a key pair set up) I had to change the Logon Type dropdown to 'Key file' which I located and loaded in.

    Worth noting, I have also changed SSH port from default 22 so I also needed to specify that in the Port field.
     
    cPanelMichael likes this.
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,734
    Likes Received:
    661
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    ItsMattSon likes this.
Loading...

Share This Page