i cant install extension pgsql

remshad

Member
Feb 13, 2011
23
0
51
i cant install extension pgsql ,

but i can see pgsql data base in cpanel (i already installed using yum, and i run /scripts/installpostgres)

but while rebuilding apache


an error showing





PGsql [More Info ↑] click here for details
Requires PostgreSQL 7.3 or higher to already be installed. You can do that with

Code:
The last time Cpanel::Easy::PHP5::Pgsql was run; step returned 0.

That just caused Cpanel::Easy::PHP5::Pgsql to be skipped.

The message it gave was:
Unable to find postgresql path

You might want to take that into consideration when choosing options and troubleshooting.

The log for that build is here: /usr/local/cpanel/logs/easy/apache/build.1297595612

please how i solve this issue ...
 

remshad

Member
Feb 13, 2011
23
0
51
and while installing i seen

Code:
[email protected] [~]# /scripts/installpostgres
This script will install PostgreSQL 7.3.x or later
If you have an older version installed you wil need to
Dump your databases to a file and then restore them
after the install as 7.3.x is not backwards compatible.
If you do not have any databases, you can just run:
  mv /var/lib/pgsql /var/lib/pgsql.old
  /sbin/service postgresql stop
  /sbin/service postgresql start
to force creating a 7.3.x style setup.  Do not do this if
you have databases that you wish to keep!

Are you sure you wish to proceed? y
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * addons: centos.mirror.iweb.ca
 * base: centos.mirror.iweb.ca
 * centosplus: mirror.science.uottawa.ca
 * epel: mirror.csclub.uwaterloo.ca
 * extras: centos.mirror.iweb.ca
 * remi: iut-info.univ-reims.fr
 * rpmforge: fr2.rpmfind.net
 * updates: centos.mirror.iweb.ca
Excluding Packages in global exclude list
Finished
855 packages excluded due to repository priority protections
Setting up Install Process
No package rh-postgresql available.
No package rh-postgresql-devel available.
No package rh-postgresql-libs available.
No package rh-postgresql-server available.
Package matching postgresql-libs-8.1.22-1.el5_5.1.x86_64 already installed. Checking for update.
Resolving Dependencies
--> Running transaction check
---> Package postgresql.x86_64 0:8.1.22-1.el5_5.1 set to be updated
---> Package postgresql-devel.x86_64 0:8.1.22-1.el5_5.1 set to be updated
--> Processing Dependency: libecpg.so.5()(64bit) for package: postgresql-devel
--> Processing Dependency: libpgtypes.so.2()(64bit) for package: postgresql-devel
--> Processing Dependency: libecpg_compat.so.2()(64bit) for package: postgresql-devel
---> Package postgresql-server.x86_64 0:8.1.22-1.el5_5.1 set to be updated
--> Finished Dependency Resolution
postgresql-devel-8.1.22-1.el5_5.1.x86_64 from updates has depsolving problems
  --> Missing Dependency: libecpg.so.5()(64bit) is needed by package postgresql-devel-8.1.22-1.el5_5.1.x86_64 (updates)
postgresql-devel-8.1.22-1.el5_5.1.x86_64 from updates has depsolving problems
  --> Missing Dependency: libpgtypes.so.2()(64bit) is needed by package postgresql-devel-8.1.22-1.el5_5.1.x86_64 (updates)
postgresql-devel-8.1.22-1.el5_5.1.x86_64 from updates has depsolving problems
  --> Missing Dependency: libecpg_compat.so.2()(64bit) is needed by package postgresql-devel-8.1.22-1.el5_5.1.x86_64 (updates)
Error: Missing Dependency: libecpg.so.5()(64bit) is needed by package postgresql-devel-8.1.22-1.el5_5.1.x86_64 (updates)
Error: Missing Dependency: libpgtypes.so.2()(64bit) is needed by package postgresql-devel-8.1.22-1.el5_5.1.x86_64 (updates)
Error: Missing Dependency: libecpg_compat.so.2()(64bit) is needed by package postgresql-devel-8.1.22-1.el5_5.1.x86_64 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
postmaster: no process killed
postmaster: no process killed
Installing DBD::Pg
        .........

        .........
        .........
        .........
You should now configure PostgreSQL from WHM!

does it face Dependency problem ?

if yes how i solve this
 

remshad

Member
Feb 13, 2011
23
0
51
after a big effort i installed /scripts/installpostgres , but unfortunatly it installing old version of pgsql (8.1.22 ) ,
i want version above 8.4 to run an php application ,


so please help me how i update it ......



Code:
[email protected] [~]# /scripts/installpostgres
This script will install PostgreSQL 7.3.x or later
If you have an older version installed you wil need to
Dump your databases to a file and then restore them
after the install as 7.3.x is not backwards compatible.
If you do not have any databases, you can just run:
  mv /var/lib/pgsql /var/lib/pgsql.old
  /sbin/service postgresql stop
  /sbin/service postgresql start
to force creating a 7.3.x style setup.  Do not do this if
you have databases that you wish to keep!

Are you sure you wish to proceed? y
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * addons: centos.mirror.iweb.ca
 * base: centos.mirror.iweb.ca
 * centosplus: mirror.science.uottawa.ca
 * epel: mirror.csclub.uwaterloo.ca
 * extras: centos.mirror.iweb.ca
 * remi: iut-info.univ-reims.fr
 * rpmforge: fr2.rpmfind.net
 * updates: centos.mirror.iweb.ca
Excluding Packages in global exclude list
Finished
855 packages excluded due to repository priority protections
Setting up Install Process
No package rh-postgresql available.
No package rh-postgresql-devel available.
No package rh-postgresql-libs available.
No package rh-postgresql-server available.
Resolving Dependencies
--> Running transaction check
---> Package postgresql.x86_64 0:8.1.22-1.el5_5.1 set to be updated
---> Package postgresql-devel.x86_64 0:8.1.22-1.el5_5.1 set to be updated
---> Package postgresql-libs.x86_64 0:8.1.22-1.el5_5.1 set to be updated
---> Package postgresql-server.x86_64 0:8.1.22-1.el5_5.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                Arch        Version                  Repository    Size
================================================================================
Installing:
 postgresql             x86_64      8.1.22-1.el5_5.1         updates      2.9 M
 postgresql-devel       x86_64      8.1.22-1.el5_5.1         updates      1.2 M
 postgresql-libs        x86_64      8.1.22-1.el5_5.1         updates      196 k
 postgresql-server      x86_64      8.1.22-1.el5_5.1         updates      3.9 M

Transaction Summary
================================================================================
Install       4 Package(s)
Upgrade       0 Package(s)

Total download size: 8.2 M
Downloading Packages:
--------------------------------------------------------------------------------
Total                                           9.4 MB/s | 8.2 MB     00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : postgresql-libs                                          1/4
  Installing     : postgresql                                               2/4
  Installing     : postgresql-server                                        3/4
warning: /var/lib/pgsql/.bash_profile created as /var/lib/pgsql/.bash_profile.rpmnew
  Installing     : postgresql-devel                                         4/4

Installed:
  postgresql.x86_64 0:8.1.22-1.el5_5.1
  postgresql-devel.x86_64 0:8.1.22-1.el5_5.1
  postgresql-libs.x86_64 0:8.1.22-1.el5_5.1
  postgresql-server.x86_64 0:8.1.22-1.el5_5.1

Complete!
postmaster: no process killed
postmaster: no process killed
Installing DBD::Pg
        .........
        .........
You should now configure PostgreSQL from WHM!
 

remshad

Member
Feb 13, 2011
23
0
51
how i install

hey , now i installed pgsql suceesfully but i want some latest version of pgsql (i used to download latest version 9.02 then installed but its not come as php extension ,so i cant use it)
how i install postgresql version above 8.4 using WHM , or ssh
now installed using /scripts/installpostgres but the version is 8.1.22-1 (i want to run a php application which require pgsql above 8.4)

and along i want to use as php extension
 
Last edited:

JaredR.

Well-Known Member
Feb 25, 2010
1,834
24
143
Houston, TX
cPanel Access Level
Root Administrator
cPanel installs the version of PostgreSQL that is offered by the operating system's update channels. For CentOS 5.5, this means PostgreSQL 8.1.22. Since cPanel only installs the version of PostgreSQL available from the operating system's update channels (we do not create our own RPM packages), we cannot support more recent versions. It is very possible that other users on the forums have done this and can assist you, but you have the latest version that cPanel will install and that we have tested and can support.

Please note that the forums are intended mainly as a community for sharing information, and that for urgent support issues, we encourage you to submit a ticket. Tickets are answered 24 hours a day, 7 days a week, including holidays, and are usually the fastest way to address support-related issues.
 

remshad

Member
Feb 13, 2011
23
0
51
yes i mean uninstall ,
bcz i dont have any use if i dont get pgsql version above 8.4 ,

"yum remove postgresql" is not working in the case , while i installed using "/scripts/installpostgres"
 
Last edited:

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
You could remove the rpms. First do the following to get the list:

Code:
rpm -qa|grep -i postgres
This will provide a list of the rpms, then you can remove each of them:

Code:
rpm -e postgresrpmname
Replace the postgresrpmname with the actual name of the rpm for each one.
 

remshad

Member
Feb 13, 2011
23
0
51
, i did , but sow error
Code:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, ***@**** and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


any way i rebuilded apache server to getrid of this server error ...

can you help me to add latest pgsql version in operating system's update channels. For CentOS 5.5 ?
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Unfortunately, installing a newer version of postgres beyond what cPanel supports is beyond what we would recommend doing. You could certainly search to find a way to do this, but I would not recommend that path if you want postgres to be functional.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello remshad,

I am going to re-quote Jared who provided very good information on this same question when asked earlier:

cPanel installs the version of PostgreSQL that is offered by the operating system's update channels. For CentOS 5.5, this means PostgreSQL 8.1.22. Since cPanel only installs the version of PostgreSQL available from the operating system's update channels (we do not create our own RPM packages), we cannot support more recent versions. It is very possible that other users on the forums have done this and can assist you, but you have the latest version that cPanel will install and that we have tested and can support.
We will be unable to support a more recent version beyond what we have tested that works with cPanel. If you change your update channels to not use the stock yum repositories, then you are going outside the regular upgrade channels and updating to a non-supported version.

What supported means here specifically is that if you use the one we provide, we support when it doesn't work for PhpPgAdmin or postgres itself does not function. You can open a ticket for free complimentary support. If you upgrade to a version we do not support, we will be unable to assist in any issues that occur where it does not work. You are welcome to upgrade beyond the version we support (currently 8.1.22) by grabbing new rpms, but we will be unable to assist with configuring this setup.

If this is still unclear, please let us know.

Thanks!
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
24
143
Houston, TX
cPanel Access Level
Root Administrator
I wanted to mention that there is already a feature request asking for cPanel to supply its own PostgreSQL, the way it already does with MySQL:

http://forums.cpanel.net/f145/cpanel-should-distribute-postgresql-not-rely-os-vendor-166170.html

I recommend that anyone interested in using newer versions of PostgreSQL than the operating system vendor provides comment on the feature request thread. This will help our developers gauge interest in this and prioritize it accordingly.