The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I can't send email with Horde, Roundcube or SquirrelMail.

Discussion in 'E-mail Discussions' started by davejames, Feb 27, 2011.

  1. davejames

    davejames Member

    Joined:
    Nov 19, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I can't send any email.

    I gives the error after try to send email:

    Failed to set sender: info@emailaddress.be [SMTP: Failed to write to socket: not connected (code: -1, response: )]


    What to do?? how to fix?


    Thanks and regards,
    Dave.
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Are you running CSF on the machine? If so, please check WHM > Plugins > ConfigServer Security&Firewall > Firewall Configuration file. In that file, ensure that "SMTP_ALLOWLOCAL" has a 1 next to it. If it does not, change to 1 and click the "Change" button, then restart CSF and LFD.
     
  3. Kristian0911

    Kristian0911 Member

    Joined:
    Jan 17, 2011
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Also check "SMTP_Block" and Change SMTP_Block to 0, restart firewall.

    Thanks.
     
  4. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    Is your issue resolved ??
     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You do not need to change SMTP_BLOCK to 0 if you have SMTP_ALLOWLOCAL with a 1. The purpose of SMTP_ALLOWLOCAL is to allow the webmail clients to still send when SMTP_BLOCK has a 1 in CSF.
     
  6. prazgod

    prazgod Member

    Joined:
    Oct 19, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I had this exact issue.

    I had csf installed.

    I set SMTP_ALLOWLOCAL to 1 and SMTP_BLOCK to 1 and now everything works

    Thanks for the thread - saved me hours of time.
     
  7. mandrak

    mandrak Registered

    Joined:
    Jan 30, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi, I just join the forum as i wish to say BIG THANK YOU for all memebres! This forum is great and I've had the exactly the same issue with sending mails. Solution was correct also in my case. Thisi is not the first time I've found help on this forum. Hope I'll help somebody else next time! Keep going!
     
  8. brentc

    brentc Member

    Joined:
    Jul 20, 2010
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I still get the same error and it appears as if some of the suggested resolutions have changed since the more recent WHM upgrades. It doesn't seem as if CSF is still being managed through WHM > Plugins > ConfigServer Security&Firewall > Firewall Configuration file. Under Plugins I have just Softaculous listed. In Tweak Settings I have disabled "Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak)" but still get the same error message. Could be something simple maybe? Not sure. Any ideas?
     
Loading...

Share This Page