I can't send email with Horde, Roundcube or SquirrelMail.

davejames

Member
Nov 19, 2010
15
0
51
I can't send any email.

I gives the error after try to send email:

Failed to set sender: [email protected] [SMTP: Failed to write to socket: not connected (code: -1, response: )]


What to do?? how to fix?


Thanks and regards,
Dave.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Are you running CSF on the machine? If so, please check WHM > Plugins > ConfigServer Security&Firewall > Firewall Configuration file. In that file, ensure that "SMTP_ALLOWLOCAL" has a 1 next to it. If it does not, change to 1 and click the "Change" button, then restart CSF and LFD.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
You do not need to change SMTP_BLOCK to 0 if you have SMTP_ALLOWLOCAL with a 1. The purpose of SMTP_ALLOWLOCAL is to allow the webmail clients to still send when SMTP_BLOCK has a 1 in CSF.
 

prazgod

Member
Oct 19, 2004
6
0
151
I had this exact issue.

I had csf installed.

I set SMTP_ALLOWLOCAL to 1 and SMTP_BLOCK to 1 and now everything works

Thanks for the thread - saved me hours of time.
 

mandrak

Registered
Jan 30, 2012
1
0
51
cPanel Access Level
Root Administrator
I had this exact issue.

I had csf installed.

I set SMTP_ALLOWLOCAL to 1 and SMTP_BLOCK to 1 and now everything works

Thanks for the thread - saved me hours of time.
Hi, I just join the forum as i wish to say BIG THANK YOU for all memebres! This forum is great and I've had the exactly the same issue with sending mails. Solution was correct also in my case. Thisi is not the first time I've found help on this forum. Hope I'll help somebody else next time! Keep going!
 

brentc

Member
Jul 20, 2010
19
0
51
Hello,

I still get the same error and it appears as if some of the suggested resolutions have changed since the more recent WHM upgrades. It doesn't seem as if CSF is still being managed through WHM > Plugins > ConfigServer Security&Firewall > Firewall Configuration file. Under Plugins I have just Softaculous listed. In Tweak Settings I have disabled "Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak)" but still get the same error message. Could be something simple maybe? Not sure. Any ideas?