warlock77

Member
Apr 24, 2006
7
0
151
Hello, Im trying to upgrade/recompile apache, but Im getting this error:

Code:
There was an error while fetching http://layer1.cpanel.net/buildapache15.rc

Died at /usr/local/cpanel/Whostmgr/LibShare.pm line 291.
	main::__ANON__('PIPE') called at /usr/local/cpanel/Whostmgr/LibShare.pm line 300
	eval {...} called at /usr/local/cpanel/Whostmgr/LibShare.pm line 285
	main::objget('http://layer1.cpanel.net/buildapache15.rc', 0) called at whostmgr/bin/whostmgr2.pl line 17021
	main::buildapache() called at whostmgr/bin/whostmgr2.pl line 703
Please, someone can help me?
WHM 11.1.0 Cpanel 11.4.11.R13914
Centos 4.5
 

JGrubbs

Active Member
Oct 12, 2005
29
0
151
I'm having the same problem too! I can use /scripts/easyapache, but getting the errors in WHM -> Software -> Apache Update.

WHM 11.1.0 cPanel 11.4.18-R14158
CENTOS Enterprise 4.5 i686 - WHM X v3.1.0
 

cooldude7273

Well-Known Member
Jan 11, 2004
357
0
166
Roswell, GA
Not sure if it will help, but run...

Code:
rm /var/cpanel/objcache/buildapache.rc /var/cpanel/objcache/buildapache15.rc
... to clear out your local buildapache cache.

and run

Code:
/scripts/upcp --force
to download it again from their server.

It's worth a try and it won't hurt anything should it not work, or hit me up on IM or a PM and I'll try and help you out! :)
 

hikaro

Well-Known Member
Nov 22, 2005
99
0
166
may i know what the exactly /scripts/upcp did?
it upgrade the cpanel or fix something else?
 

cooldude7273

Well-Known Member
Jan 11, 2004
357
0
166
Roswell, GA
may i know what the exactly /scripts/upcp did?
it upgrade the cpanel or fix something else?
/scripts/upcp will update cPanel and portions of your server. Using it with --force will reinstall portions of cPanel which may fix some problems. It won't hurt anything.