The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I change or add pages ... but they wont show up on the internet?

Discussion in 'General Discussion' started by rockybloggs143, Nov 20, 2009.

  1. rockybloggs143

    rockybloggs143 Registered

    Joined:
    Nov 20, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi guys, I am hoping someone can help me here, my hosting company has tried to help me but they keep saying that it must be my browser. Its not, as I have tried in firefox and ie on two different computers.


    What is happening is, I try to change a page, or even add a whole new page, but they wont show up on the internet.

    What is strange is that for instance, I completely deleted the index page and made a new one, but the old one still shows up on the internet! But in cpanel, if I click the edit HTML button, it will show the new page.

    Not only that but since this started happening, 5 days ago, my stats are no longer showing. The past 5 days show 0. But my hosting company says that when they go in and look, they can see the stats.

    I attached a screen shot of my cpanel file manager, as you can see, there is a page named "graphics"
    yet if you go to: http://www.theweekendworker.com/graphics.htm it comes up with a 404 error page!

    It is really frustrating, I cannot update, or add anything!
    Thanks for the help!
     

    Attached Files:

  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,452
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    This looks to me to be more of a wordpress blog issue than a cPanel issue. That is a wordpress blog, correct?
     
  3. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    The inability to access custom HTML pages outside of the WordPress script may be due to Apache mod_rewrite directives from WordPress; these entries are located in the file named ".htaccess" located in the same directory as WordPress.

    I recommend to temporarily rename the file ".htaccess" to effectively disable the mod_rewrite entries if they exist then re-test accessing the custom HTML pages.
     
  4. mickbeng

    mickbeng Well-Known Member

    Joined:
    Oct 3, 2006
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Penang, Malaysia
    Be aware that if you remove the mod_rewrite, your wordpress permalink will gone, but you have not choice because you have to have the graphics.htm work. ;)

    I will suggest you change the WordPress permalink to default setting and try to add # to each of the line as following script from the .htaccess.

    Code:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
     
Loading...

Share This Page