I changed the IP of Exim, but what about cgi/php scripts?

noimad1

Well-Known Member
Mar 27, 2003
628
0
166
I successfully changed the IP address in the exim.conf and exim_outgoing.conf files and that seems to work ok.

However, it seems like mail sent through cgi and php scripts still goes out over the old IP address. Did I miss something, or is this even possible to change?
 

mctDarren

Well-Known Member
Jan 6, 2004
665
4
168
New Jersey
cPanel Access Level
Root Administrator
Hmm, now that I think on this - cPanel usually has Exim take over sendmail, so that might not be the problem at all... Weird...

Does your server's hostname still resolve to the old IP? Look for a "primary_hostname=" line in your exim.conf maybe, and see what it resolves to...
 

noimad1

Well-Known Member
Mar 27, 2003
628
0
166
Hmm, now that I think on this - cPanel usually has Exim take over sendmail, so that might not be the problem at all... Weird...

Does your server's hostname still resolve to the old IP? Look for a "primary_hostname=" line in your exim.conf maybe, and see what it resolves to...
I'm not seeing a "primary_hostname=" in the exim.conf file..? I do see one in the exim_outgoing.cnf file, but it is blank and commented out?

My host name does still resolve to the old IP address because I was just wanting to change the mail IP address, and not the shared IP address itself?
 

mctDarren

Well-Known Member
Jan 6, 2004
665
4
168
New Jersey
cPanel Access Level
Root Administrator
Hm, very weird if it's sending out over your new IP for other accounts, but scripts are not. Might want to put in a support ticket or wait for Chirpy or someone more familiar with the Exim process as a whole to comment. Sorry! I've never run into this one before. But I was under the assumption that it used the hostname to send out mail for everyone...
 

noimad1

Well-Known Member
Mar 27, 2003
628
0
166
Ok, maybe I'm smoking something or I'm just loosing it. I just did some more tests and the scripts are sending out using the new IP....