The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I get this errors after security easyapache upgrade

Discussion in 'EasyApache' started by kran, Oct 22, 2004.

  1. kran

    kran Well-Known Member

    Joined:
    Jul 5, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Colombia
    cPanel Access Level:
    Root Administrator
    make ming-0.3beta1...(install).... Done
    gifdbl.c:31: syntax error before '*' token
    gifdbl.c: In function `getTransparentColor':
    gifdbl.c:34: `ExtensionBlock' undeclared (first use in this function)
    gifdbl.c:34: (Each undeclared identifier is reported only once
    gifdbl.c:34: for each function it appears in.)
    gifdbl.c:34: `ext' undeclared (first use in this function)
    gifdbl.c:34: `file' undeclared (first use in this function)
    gifdbl.c:38: `GRAPHICS_EXT_FUNC_CODE' undeclared (first use in this function)
    gifdbl.c:36: warning: value computed is not used
    gifdbl.c: At top level:
    gifdbl.c:49: syntax error before '*' token
    gifdbl.c: In function `readGif':
    gifdbl.c:51: `ColorMapObject' undeclared (first use in this function)
    gifdbl.c:51: `colorMap' undeclared (first use in this function)
    gifdbl.c:58: warning: implicit declaration of function `DGifSlurp'
    gifdbl.c:58: `file' undeclared (first use in this function)
    gifdbl.c:58: `GIF_OK' undeclared (first use in this function)
    gifdbl.c:87: `result' undeclared (first use in this function)
    gifdbl.c:115: `GifColorType' undeclared (first use in this function)
    gifdbl.c:115: syntax error before "c"
    gifdbl.c:118: `c' undeclared (first use in this function)
    gifdbl.c:189: warning: implicit declaration of function `DGifCloseFile'
    gifdbl.c: In function `newSWFDBLBitmapData_fromGifFile':
    gifdbl.c:210: `GifFileType' undeclared (first use in this function)
    gifdbl.c:210: `file' undeclared (first use in this function)
    gifdbl.c:214: warning: implicit declaration of function `DGifOpenFileName'
    gifdbl.c: At top level:
    gifdbl.c:223: syntax error before '*' token
    gifdbl.c: In function `gifReadFunc':
    gifdbl.c:224: `gif' undeclared (first use in this function)
    gifdbl.c:225: `buf' undeclared (first use in this function)
    gifdbl.c:225: `len' undeclared (first use in this function)
    gifdbl.c: In function `newSWFDBLBitmapData_fromGifInput':
    gifdbl.c:229: `GifFileType' undeclared (first use in this function)
    gifdbl.c:229: `file' undeclared (first use in this function)
    gifdbl.c:233: warning: implicit declaration of function `DGifOpen'
    gifdbl.c:233: `InputFunc' undeclared (first use in this function)
    gifdbl.c:233: syntax error before "gifReadFunc"

    /usr/include/bits/mathinline.h: At top level:
    gifdbl.c:224: warning: `gifReadFunc' defined but not used
    make[2]: *** [gifdbl.o] Error 1
    make[1]: *** [dynamic] Error 2
    make: *** [dynamic] Error 2

    Untarring imap....imap-devel is installed!
    Untarring php....Done
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 563 (offset 18 lines).
    Hunk #2 succeeded at 891 (offset 6 lines).

    configure php-4.3.9...(--with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --with-curl --with-dom --with-dom-xslt --with-dom-exslt --enable-exif --with-swf=/usr/local/flash --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-gettext --with-imap --with-imap-ssl --with-kerberos --with-mcrypt --with-mhash --with-ming=../ming-0.2a --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-safe-mode --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --enable-versioning --enable-wddx --with-xmlrpc --with-zip --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

    make php-4.3.9...(clean).... Done

    make php-4.3.9....... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    make: *** [sapi/cli/php] Error 1

    make php-4.3.9...(install).... . . Done
    make: *** [sapi/cli/php] Error 1

    ANY IDEAS WHATS CAUSING IT?
     
  2. Secret Agent

    Secret Agent Guest

    Me too. Strange because it happened on my Fedora Core 2 box but not my RHE
     
  3. kran

    kran Well-Known Member

    Joined:
    Jul 5, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Colombia
    cPanel Access Level:
    Root Administrator
    It happened with RHE

    I belive is with ming any one knows how to solve this issue?
     
  4. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    I'm having these issues also - RHEL 3
     
  5. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    Was about to run easyapache, glad i read this post first lol.
     
  6. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    Same error here
     
  7. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    16
    Anyone file a trouble ticket with cPanel?
     
  8. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    I just opened a ticket, hope they fix it soon.
     
  9. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Make sure you have libungif-devel installed
     
  10. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    According to WHM i have libungif installed but not libungif-devel. Is it necessary to have both?

    Just to make sure, the RPM's that appear in the list with "(reinstall)" beside them are RPMS that are currently installed right?
     
  11. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    Thank you Nick, that fixed the problem.

    damainman, install the devel too.
     
Loading...

Share This Page