The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I have a port open, how can i telnet to it?

Discussion in 'General Discussion' started by AbeFroman, Sep 7, 2004.

  1. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    I am trying to get a bash prompt, how do i do this?

    root@server [~]# telnet 69.xx.xx.xx 34375
    Trying 69.xx.xx.xx...
    Connected to 69.xx.xx.xx.
    Escape character is '^]'.

    hi
    bash

    e^Hls
    ls


    lCan't fork pty, bye!
    Connection closed by foreign host.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You can only telnet to a port and get a bash prompt if you've got something running behind that port that serves up a shell :rolleyes: For example, the telnet daemon (disabled by default) or a hackers tool installed on a compromised server, etc :eek:

    If you're just telnetting to an open port that is connected to a process, then you need to speak whatever language that port expects. E.g., telnet to port 25 and you will have to talk SMTP.
     
  3. Drake

    Drake Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    True, we don't want to run telnet daemon listening on port 25.

    But if you're just trying to log into the shell (bash, or shell prompt), then try using an SSH client instead of Telnet. Be sure that the SSH daemon is running on the server, and try to connect via port 22. PuTTY is a good ssh client, and is available free to download off the internet.

    Additionally, whatever USERNAME you will choose to connect as, must have shell access permissions as well.

    Hope I have been of help.

    ~Drake
     
Loading...

Share This Page