I have a problem with load average on my cPanel server.

Bakowang

Member
Oct 27, 2014
5
0
1
United Kingdom
cPanel Access Level
Root Administrator
Hello Guys.
Please help me i have a problem with load, i have load on two hosting account on my server, how can i fix it by csf ? or who have any suggestions please make suggestions to me


error load.PNG

Code:
Pid	Owner	Priority	CPU %	Memory %	Command
21221 (Trace) (Kill)	543	0	  9.2	  1.1	/usr/bin/php /home/username/public_html/index.php
21228 (Trace) (Kill)	543	0	  7.6	  0.9	/usr/bin/php /home/username/public_html/index.php
21229 (Trace) (Kill)	543	0	  7.6	  0.9	/usr/bin/php /home/username/public_html/index.php
21232 (Trace) (Kill)	543	0	  5.3	  0.8	/usr/bin/php /home/username/public_html/index.php
21230 (Trace) (Kill)	543	0	  5.3	  0.7	/usr/bin/php /home/username/public_html/index.php
21226 (Trace) (Kill)	543	0	  4.3	  0.7	/usr/bin/php /home/username/public_html/index.php
21227 (Trace) (Kill)	543	0	  4.3	  0.7	/usr/bin/php /home/username/public_html/index.php
21234 (Trace) (Kill)	543	0	  4.3	  0.7	/usr/bin/php /home/username/public_html/index.php
21265 (Trace) (Kill)	root	0	  2.6	  2.1	whostmgr2 - top ./top
21260 (Trace) (Kill)	543	0	  2.6	  0.5	/usr/bin/php /home/username/public_html/index.php
21284 (Trace) (Kill)	543	0	  1.0	0.3	/usr/bin/php /home/username/public_html/index.php
21269 (Trace) (Kill)	543	0	  1.0	0.0	[php] <defunct>
21270 (Trace) (Kill)	543	0	  1.0	0.0	[php] <defunct>
21271 (Trace) (Kill)	543	0	  1.0	0.0	[php] <defunct>
21272 (Trace) (Kill)	543	0	  1.0	0.0	[php] <defunct>
21278 (Trace) (Kill)	543	0	  1.0	0.0	[php] <defunct>
21279 (Trace) (Kill)	543	0	  1.0	0.0	[php] <defunct>
21111 (Trace) (Kill)	uyi546ui	0	  0.8	0.4	/usr/bin/php /home/username2/public_html/index.php
1890 (Trace) (Kill)	mysql	0	  0.7	  2.7	/usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin --user=mysql --log-error=/var/lib/mysql/server.domain.co.uk.err --open-files-limit=8192 --pid-file=/var/lib/mysql/server.domain.co.uk.pid
i happy who suggestions to me.
 
Last edited by a moderator:

postcd

Well-Known Member
Oct 22, 2010
717
19
68
why do you think you have high load? it dont appears like that much
cpu/ram/hdd?

check "top" command headers to see if cause is ram, cpu or disk (high %wa) value
 

Bakowang

Member
Oct 27, 2014
5
0
1
United Kingdom
cPanel Access Level
Root Administrator
here is my service status check here.

Server load 84.22 (2 CPUs)
Memory Used 57.01% (1,793,240 of 3,145,728)
Swap Used 27.49% (864,700 of 3,145,728)

- - - Updated - - -

load average is Load Averages: 11.12 25.48 16.89
 

postcd

Well-Known Member
Oct 22, 2010
717
19
68
WHM /System health / Process Manager can also tell you which processes consuming most CPU
Also you can try linux "top" command to see if %wa value is not high (>10), it can tell you HDD has too much work.
 

Bakowang

Member
Oct 27, 2014
5
0
1
United Kingdom
cPanel Access Level
Root Administrator
when on here domain domain.com get to some refresh page it's reading some high load some time Load Averages: going to 48.12 7.23 8.00 or 68.12 7.23 8.00 i don't know why it's high load when refresh or someone visit here domain. going to up load average. and when going to 48.12 7.23 8.00 page whm and some position pages going to very slow. i don't know about this problem can you understand this problem?

this domain use wordpress
 

postcd

Well-Known Member
Oct 22, 2010
717
19
68
Your website is quite big (thanks to images). Try to follow optimization advices from webpagetest.org or gtmetrix.com, tools.pingdom.com
high cpu can be also because of badly optimized wordpress blugins maybe