I need help about upgrading to apache2/php5

xserverx

Member
Jun 10, 2007
24
0
151
hello ,


I would like upgrading to apache2.X and PHP5.x I have some question about that , can I find details how can I make upgrade without any problem ,
in cpanel (aptche upgrade ) what modules can I check it befor upgrading I don't know what need to check ?? is my sites working well without problem after upgrading ??


please help me
 

brooktdf

Member
Oct 31, 2007
8
0
51
in the sky
I can't say exactly about the apache, but when i had to upgrade my php i yust copied the files of php5 over the old files (php4) with auot-replace. Everything was ok.
ps. had Win32 system tho
 

xserverx

Member
Jun 10, 2007
24
0
151
I can't say exactly about the apache, but when i had to upgrade my php i yust copied the files of php5 over the old files (php4) with auot-replace. Everything was ok.
ps. had Win32 system tho
is very easy from Cpanel I talk about how is the problem I across when I make apache build with apache2 and php5 and what is modules need to chose befor upgrading ?
 

sarhosting

Well-Known Member
Oct 1, 2007
170
2
68
United States
cPanel Access Level
Root Administrator
Twitter
To update Apache you first need to be running the Edge version of cPanel to get al the necessary scripts. I wouldn't reccomend doing this, unless you are very familiar with SSH - its can be a nightmare but very easy to do and should only take 20 minutes or so to compile if you really know what your doing, we have all 10 of our servers running on apache 2.2 and php 5.2.4

PM me if you get stuck.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
To update Apache you first need to be running the Edge version of cPanel to get al the necessary scripts. I wouldn't reccomend doing this, unless you are very familiar with SSH - its can be a nightmare but very easy to do and should only take 20 minutes or so to compile if you really know what your doing, we have all 10 of our servers running on apache 2.2 and php 5.2.4

PM me if you get stuck.
That is incorrect. Release, Current and EDGE all have EA3 which brings in Apache 2.x et al. All necessary support is in those branches, one simply needs to keep their install updated.