Upgrading to 2.4 shouldn't be a problem. My long term plan is to that with CloudLinux etc. My biggest issue will be changes of IP. Way to many of my customers control the dns from their registrar etc.Also there are issues with with Apache 2.2, we really need to be running 2.4 now to support TLSv1.1.
You can give up PCI Compliance and assume the risk of using TLSv1 or get a new server. If you upgrade (buy a new server and migrate) that uses CENTOS 6.6 with CloudLinux, then the server would support users selecting a different version of PHP without risk to the server and clients who are using the most current version by using CageFS. The older versions would NOT effect users PCI Compliance, since it isn't running in their cage. It would only effect users who were actually using the old version.
That was the solution I picked. Obviously, this isn't urgent. You can upgrade between now and June of 2016 and still be compliant.
Thanks for your help.