The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

i need to enable register_globals

Discussion in 'General Discussion' started by einSTein86, Jan 11, 2009.

  1. einSTein86

    einSTein86 Registered

    Joined:
    Jan 8, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    i got hosting with cPanel Control panel i have some problem with this hosting because its "register_globals" disabled , i need to enable the "register_globals" on my hosting , please help me in enabling my "register_globals" on my hosting as soon as possible
     
  2. JawadArshad

    JawadArshad Well-Known Member
    PartnerNOC

    Joined:
    Apr 8, 2008
    Messages:
    447
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    PK
    cPanel Access Level:
    DataCenter Provider
    Do you have root access or have only cPanel access. In the first case, you need to do it in the php.ini file of your server although enabling register_globals is not recommended for security reasons. SuPHP allows you to enable register_globals on a per user basis by placing a local php.ini file in the public_html folder or any folder in your account.
    If you only have cPanel access, ask your host and they will do it for you.
     
  3. einSTein86

    einSTein86 Registered

    Joined:
    Jan 8, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    i have a root access but i need to wt to do exactly in steps please
     
  4. JawadArshad

    JawadArshad Well-Known Member
    PartnerNOC

    Joined:
    Apr 8, 2008
    Messages:
    447
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    PK
    cPanel Access Level:
    DataCenter Provider
    Make sure you know the security concerns related with register_globals. If you really want to turn it on, login to shell.

    1- Run the command below.

    whereis php.ini

    This will give you a path like below.

    ==
    root@server [~]# whereis php.ini
    php: /usr/bin/php /usr/lib/php /usr/lib/php.ini /usr/local/bin/php /usr/local/lib/php.ini,v /usr/local/lib/php /usr/local/lib/php.ini /usr/include/php
    ==


    2- Now edit the file using vi editor and search register_globals

    vi /usr/local/lib/php.ini

    Change the value from Off to On

    If you are running SuPHP, you can just copy the php.ini file in the account where you want to turn on this variable and then change its value. This will keep register_globals off globally but on for the single account.
     
  5. einSTein86

    einSTein86 Registered

    Joined:
    Jan 8, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    i have putty i made public and private keys to the ssh of the hosting but i can't log on it can u help me ??
     
  6. JawadArshad

    JawadArshad Well-Known Member
    PartnerNOC

    Joined:
    Apr 8, 2008
    Messages:
    447
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    PK
    cPanel Access Level:
    DataCenter Provider
    If you cannot log in to your server remotely via SSH, no one other than someone present at your data center can help you. Contact your host and I am sure they will help you connect to your server via SSH.
     
Loading...

Share This Page