Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

I receive this error Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates) need to correct.

Discussion in 'General Discussion' started by rscrobinmx99, Jan 31, 2014.

  1. rscrobinmx99

    rscrobinmx99 Member

    Joined:
    Sep 12, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Subject Line is: Cron <root@server> /usr/bin/yum -y -R 120 -d 0 -e 0 update

    from: Cron Daemon
    to: root

    Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates)
    Requires: kernel >= 2.6.32-358.2.1
    Installed: kernel-2.6.32-358.el6.x86_64 (@anaconda-CentOS-201303050102.x86_64/6.4)
    kernel = 2.6.32-358.el6
    kernel = 2.6.32-358.el6
    You could try using --skip-broken to work around the problem
    ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
    sendmail-cf-8.14.4-8.el6.noarch has missing requires of sendmail = ('0', '8.14.4', '8.el6')

    I have already tried running, ulsetup, and upcp to no avail.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Re: I receive this error Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates) need to correct

    Hello :)

    That message indicates your system package manager (YUM) is unable to update a package successfully. It indicates the "irqbalance" RPM requires the following kernel version or higher:

    2.6.32-358.2.1

    Do you receive any output when running "yum update" on it's own? Also, please post the output of:

    Code:
    uname -a
    Note that this is an OS-level issue that is not associated with the cPanel software.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. rscrobinmx99

    rscrobinmx99 Member

    Joined:
    Sep 12, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: I receive this error Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates) need to correct

    Here are the stuffs.

    uname -a

     
  4. Kraxsis

    Kraxsis Registered

    Joined:
    Feb 1, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: I receive this error Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates) need to correct

    I too am have this issue:

    [5007] checkyum version 21.1
    [20140201.200606] [5007] Loaded plugins: fastestmirror, security
    [20140201.200606] [5007] Loading mirror speeds from cached hostfile
    [20140201.200607] [5007] * rpmforge: mirror.hmc.edu
    [20140201.200609] [5007] Setting up Update Process
    [20140201.200612] [5007] Resolving Dependencies
    [20140201.200612] [5007] --> Running transaction check
    [20140201.200612] [5007] ---> Package irqbalance.x86_64 2:1.0.4-6.el6 will be updated
    [20140201.200612] [5007] ---> Package irqbalance.x86_64 2:1.0.4-8.el6_5 will be an update
    [20140201.200612] [5007] --> Processing Dependency: kernel >= 2.6.32-358.2.1 for package: 2:irqbalance-1.0.4-8.el6_5.x86_64
    [20140201.200612] [5007] ---> Package p11-kit.x86_64 0:0.18.5-2.el6 will be updated
    [20140201.200612] [5007] ---> Package p11-kit.x86_64 0:0.18.5-2.el6_5.2 will be an update
    [20140201.200612] [5007] ---> Package p11-kit-trust.x86_64 0:0.18.5-2.el6 will be updated
    [20140201.200612] [5007] ---> Package p11-kit-trust.x86_64 0:0.18.5-2.el6_5.2 will be an update
    [20140201.200612] [5007] ---> Package tzdata.noarch 0:2013i-1.el6 will be updated
    [20140201.200612] [5007] ---> Package tzdata.noarch 0:2013i-2.el6 will be an update
    [20140201.200612] [5007] --> Finished Dependency Resolution
    [20140201.200612] [5007] Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates)
    [20140201.200612] [5007] Requires: kernel >= 2.6.32-358.2.1
    [20140201.200612] [5007] Installed: kernel-2.6.32-358.el6.x86_64 (@anaconda-CentOS-201303050102.x86_64/6.4)
    [20140201.200612] [5007] kernel = 2.6.32-358.el6
    [20140201.200612] [5007] kernel = 2.6.32-358.el6

    and
    [root@server ~]# uname -a
    Linux server 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

    any insight would be fabulous.
     
  5. Kraxsis

    Kraxsis Registered

    Joined:
    Feb 1, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: I receive this error Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates) need to correct

    ok I actually fixed this by checking my /etc/yum.repos/CentOS-Base.repo and there was a line that read:
    exclude=kernel* iptables* iproute puppet* facter
    So I commented that out.
    Then ran yum update kernel
    updated my kernel to 2.6.32-431.3.1.el6.x86_64
    uncommented out that line then re-ran yum update
    and my irqbalance updated just fine.

    Thought I would pass this on.
     
  6. rscrobinmx99

    rscrobinmx99 Member

    Joined:
    Sep 12, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: I receive this error Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates) need to correct

    Who is your hosting provider?
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Re: I receive this error Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates) need to correct

    I am happy to see that you have resolved the issue. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. rscrobinmx99

    rscrobinmx99 Member

    Joined:
    Sep 12, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: I receive this error Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates) need to correct

    I think the previous posted misunderstood the issue.

    ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
    sendmail-cf-8.14.4-8.el6.noarch has missing requires of sendmail = ('0', '8.14.4', '8.el6')
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Re: I receive this error Error: Package: 2:irqbalance-1.0.4-8.el6_5.x86_64 (updates) need to correct

    sendmail-cf is not a standard cPanel package. You can try adding an exclusion for it in /etc/yum.conf or remove it if you no longer require it.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice