The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IDN domain HOSTING (names with UTF-8 characters)

Discussion in 'General Discussion' started by basic, Jul 29, 2010.

  1. basic

    basic Active Member

    Joined:
    Nov 10, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Hello All:

    Please forgive me for the not 100% technical correct subject line -- I simplified:

    PROBLEM: There seems no way to *host* a IDN Domain on a Linux/cPanel server so that the domain name will actually show that name in the web browser window correctly (without converting it to Punycode). Or is there? That is my question. If not, are there other hosting panels that allow that -- or, to rephrase, HOW do I get there?

    EXAMPLE:
    http://www.ñandú.cl/
    This IDN Domain actually shows the two accents in the web browser.
    However, if I would host it on a cPanel server, then it will only show:
    http://www.xn--and-6ma2c.cl/

    I have even seen websites in Asia -- and the same is true for above EXAMPLE, where, when I enter the Asian language .com name in Punycode, then the server actually converts it into native national script (characters) in the browser window. My own cPanel servers only do it reverse, and that is not at all helpful!


    Is there a way to do this?


    Best,
    John
     
    #1 basic, Jul 29, 2010
    Last edited: Jul 29, 2010
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    When using IDNs the information being relayed between your browser and the server is actually the punycode representation of the IDN. The browser performs the conversion, not the server.

    As for the specific problem you are experiencing you need to take the matter up with your host provider. If you are the host provider then I recommend opening a support ticket with our support staff.
     
  3. basic

    basic Active Member

    Joined:
    Nov 10, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Hi Kenneth:

    Thanks for taking the time to reply.

    A few notes:
    (1) The browser does its work -- I can see that when I access e.g. some domains in Chinese or Korean (on other servers, not our's), and the browser window still displayes them in the original characters ... or the sample I gave here in my posting.
    (2) Yes, I/we are the host, we have several racks and many Linux cPanel servers. I did mention this problem about two months ago in a ticket, and someone really looked into it -- but there was no solution. The reason I am posting it here is NOT to criticize cPanel techs in any way, not at all! I just thought that the "problem" might not even relate to cPanel ...maybe some Linux issue? Yesterday night I tested this on a Plesk server (also running CentOS 5.x), and it did not work there either. .... But obviously it does work on servers, maybe only on Windows servers? No idea what it could be. Maybe someone here knows???

    Best,
    John
     
  4. basic

    basic Active Member

    Joined:
    Nov 10, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    U p d a t e :

    It seems the answer to this issue can be found here (2nd posting in here):
    How to display correct IDN inside FF? (in other browsers are correct)

    Firefox (Mozilla) simply does not display IDN in e.g. .com, .net, .org, or .eu domain TLDs.
    --> IDN-enabled TLDs
    But it does in, for example, .de (Germany), .es (Spain), or .jp (Japan).
    So, if I register a name with Japanese script and a .jp TLD, that works, but not for a .com domain, where it is also possible to register one, the Japanese script would be converted to Punycode if I use Firefox as a browser.


    John
     
    #4 basic, Aug 1, 2010
    Last edited: Aug 1, 2010
Loading...

Share This Page