if status code 404 cpanel sets local IP in error_log

serpent_driver

Active Member
Aug 1, 2019
29
7
8
Home
cPanel Access Level
Root Administrator
Hello,

if I check my error_log in all accounts cpanel sets local IP (127.0.0.1) or server IP instead of the IP from user who requested the URL. It doesn't matter what kind of URL it is and can reproduce it by myself. It is not only a "issue" of my server and can find the same at my customers server. I already asked Litespeed support if this behavior is caused by Litespeed, but they checked my server and can't find any error or disfunction.

It is strange, because this does not happen with every error entry, but with many. Any ideas how to solve it or is it a "feature"?

Thank you
Michael
 

serpent_driver

Active Member
Aug 1, 2019
29
7
8
Home
cPanel Access Level
Root Administrator
No, I am not using CDN.

178.162.211.xxx is my webservers IP



Code:
2020-01-30 19:12:49.287411 [INFO] [18403] [127.0.0.1:51320-2#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/Autohaendler/Nordrhein-Westfalen/Castrop-Rauxel/]
2020-01-30 14:56:17.542997 [INFO] [18403] [127.0.0.1:55862-1#APVH_xxxxx.com] File not found [/home/xxxxx/public_html/blog/wp-admin/]
2020-01-30 11:38:38.790073 [INFO] [18403] [127.0.0.1:51320-1#APVH_xxxxx.com] File not found [/home/xxxxx/public_html/blog/wp-admin/]
2020-01-30 11:00:36.688503 [INFO] [18403] [127.0.0.1:55862-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/wp/wp-admin/]
2020-01-30 08:37:12.906575 [INFO] [18403] [127.0.0.1:51904-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/templates_c/static/jquery_mobile.js-jquery.nyroModal.custom.min.js-jquery.sumoselect.mobile.min.js]
2020-01-25 16:24:24.819455 [INFO] [7727] [178.162.211.xxx:41234-2#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/templates_c/static/jquery_mobile.js-jquery.nyroModal.custom.min.js-jquery.sumoselect.mobile.min.js]
2020-01-25 16:24:23.812205 [INFO] [7727] [178.162.211.xxx:41234-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/templates_c/static/m_styles.css-font-awesome.min.css-sumoselect.css-m_nyromodal.css]
2020-01-25 14:32:15.803230 [INFO] [7727] [178.162.211.xxx:41420-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/Autohaendler/Baden-Wuerttemberg/Horb/Hirsch-Automobile::73897.html ]
2020-01-25 13:18:13.814255 [INFO] [7727] [178.162.211.xxx:41376-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/images/product_images/original_images/83736_0.jpg]
2020-01-25 08:41:20.615423 [INFO] [7727] [178.162.211.xxx:41234-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/Autohaendler/Baden-Wuerttemberg/]
2020-01-24 23:20:45.635083 [INFO] [7727] [178.162.211.xxx:41376-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/apple-touch-icon-152x152.png]
2020-01-24 23:20:45.577042 [INFO] [7727] [178.162.211.xxx:41376-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/apple-touch-icon-152x152-precomposed.png]
2020-01-24 19:48:09.585212 [INFO] [7727] [178.162.211.xxx:41234-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/test/wp-admin/]
2020-01-24 18:50:19.903951 [INFO] [7727] [178.162.211.xxx:41234-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/Autohaendler/Sachsen-Anhalt/Schkopau/Kfz...]
2020-01-24 18:02:14.234303 [INFO] [7727] [178.162.211.xxx:41234-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/Autohaendler/Nordrhein-Westfalen/Hagen/Autoring-Hagen::89599.html ]
2020-01-24 18:01:56.582518 [INFO] [7727] [178.162.211.xxx:41928-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/Autohaendler/Niedersachsen/Zetel/Autohaus-Claas-Penning-GmbH::81686.html ]
2020-01-24 18:00:15.729704 [INFO] [7727] [127.0.0.1:52816-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/Autohaendler/Mecklenburg-Vorpommern/Bad-Doberan/Autohaus-Selck-GmbH::80820.html ]
2020-01-24 15:40:44.451498 [INFO] [7727] [178.162.211.xxx:41234-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/templates_c/static/jquery_mobile.js-jquery.nyroModal.custom.min.js-jquery.sumoselect.mobile.min.js]
2020-01-24 12:53:19.817587 [INFO] [7727] [178.162.211.xxx:41928-1#APVH_xxxxx.com] File not found [/home/xxxxx/public_html/blog/wp-admin/]
2020-01-24 11:58:19.972075 [INFO] [7727] [127.0.0.1:52816-1#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/autokatalog.php]
2020-01-24 11:09:30.515183 [INFO] [7727] [178.162.211.xxx:40892-2#APVH_xxxxx.com:443] File not found [/home/xxxxx/public_html/Autohaendler/Mecklenburg-Vorpommern/Rostock/]
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
Do you have anything in the .htaccess or any proxy added for the account/server? The docs might be helpful as well cPanel - LiteSpeed Documentation - LiteSpeed Web Server

If you're not able to identify the cause you're more than welcome to open a ticket with us. If you do open one please update this thread with the ticket ID
 

serpent_driver

Active Member
Aug 1, 2019
29
7
8
Home
cPanel Access Level
Root Administrator
Ofcourse I have some custom defines in my .htaccess. Litespeed Cache Rules, URL Rewriting rules, but nothing that can cause such issue like a proxy server. Remember my first post. This issue doesn't happend only on my server. I have a customer who setuped his server 1 week ago. This server is quite new without special configs and he has the same problem. He also uses Litespeed.

I will open a ticket to get help.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
Hello @serpent_driver

I checked in on that ticket and it would appear that you ended up opening a ticket with litespeed, in which they identified this issue was on their end and they resolved it. What did they end up doing to resolve the issue?

Thanks!
 

serpent_driver

Active Member
Aug 1, 2019
29
7
8
Home
cPanel Access Level
Root Administrator
I have no information what they have exactly done to fix it. I only get the information that error log ID was not properly cleared, so it was reused in next request and will be fixed in next build.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
Ahh interesting, I can ask them as well. I'll send a message to see if I can find out anything so it can be added here for others. Thanks, @serpent_driver for the info
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
I found the following from them in their changelog for 5.4.5 and according to the Litespeed staff I discussed this with 5.4.5 is slated to be released today
[Bug Fix] Fixed a bug using the wrong log ID in error log.

You can see it here: litespeed_wiki:changelog [LiteSpeed Wiki]

The most detail I was able to ascertain was that the error log entry from the previous request was not being cleared and that was causing it to log 127.0.0.1 for some items