ignore something being written to apache error log

sohlinux

Active Member
Sep 26, 2008
27
0
51
Hello, In my apache error log I am getting 1000s of entries like the following, how can I fix this or at least stop it being logged to the apache error log? is there a way to ignore/exclude this? , it looks like it is related to ffmpeg which in fact is working fine so just ignoring the error would be fine. thanks

[Fri Sep 23 23:47:35.518563 2016] [:error] [pid 4983] [client 127.0.0.1:29140] configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --optflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic' --enable-bzlib --disable-crystalhd --enable-gnutls --enable-ladspa --enable-libass --enable-libcdio --enable-libdc1394 --enable-libfaac --enable-nonfree --enable-libfdk-aac --enable-nonfree --disable-indev=jack --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-openal --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libx264 --enable-libx265 --enable-libxvid --enable-x11grab --enable-avfilter --enable-avresample --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib64 --enable-runtime-cpudetect
[Fri Sep 23 23:47:35.518605 2016] [:error] [pid 4983] [client 127.0.0.1:29140] libavutil 54. 20.100 / 54. 20.100
[Fri Sep 23 23:47:35.518633 2016] [:error] [pid 4983] [client 127.0.0.1:29140] libavcodec 56. 26.100 / 56. 26.100
[Fri Sep 23 23:47:35.518661 2016] [:error] [pid 4983] [client 127.0.0.1:29140] libavformat 56. 25.101 / 56. 25.101
[Fri Sep 23 23:47:35.518689 2016] [:error] [pid 4983] [client 127.0.0.1:29140] libavdevice 56. 4.100 / 56. 4.100
[Fri Sep 23 23:47:35.518717 2016] [:error] [pid 4983] [client 127.0.0.1:29140] libavfilter 5. 11.102 / 5. 11.102
[Fri Sep 23 23:47:35.518745 2016] [:error] [pid 4983] [client 127.0.0.1:29140] libavresample 2. 1. 0 / 2. 1. 0
[Fri Sep 23 23:47:35.518781 2016] [:error] [pid 4983] [client 127.0.0.1:29140] libswscale 3. 1.101 / 3. 1.101
[Fri Sep 23 23:47:35.518813 2016] [:error] [pid 4983] [client 127.0.0.1:29140] libswresample 1. 1.100 / 1. 1.100
[Fri Sep 23 23:47:35.518842 2016] [:error] [pid 4983] [client 127.0.0.1:29140] libpostproc 53. 3.100 / 53. 3.100
[Fri Sep 23 23:47:35.518859 2016] [:error] [pid 4983] [client 127.0.0.1:29140] /: Is a directory
 

24x7server

Well-Known Member
Apr 17, 2013
1,911
96
78
India
cPanel Access Level
Root Administrator
Twitter
Hello :),

Might be there is an issues with the ffmpeg modules, Your scripts is require some modules and which are not installed on your server and due to that you are getting all these logs in Apache error logs file.
 

sohlinux

Active Member
Sep 26, 2008
27
0
51
yes but ffmpeg is working just fine so just ignoring the error would be OK but how can I exclude this being logged to the apache error_log. im getting 1000s of entries per day and each is 18 lines long so the error log is massive.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,225
463