The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Illegal domain name creation

Discussion in 'General Discussion' started by shacker23, Apr 17, 2008.

  1. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    A client requested a domain name in the form of "noun+noun.com". WHM let me set up his account with this name. But when I went to register this domain, the registrar said "Illegal character in domain name - only letters, numbers and hyphens are allowed."

    Is the registrar wrong, or was WHM wrong to let me create an account with this domain name?

    Thanks,
    Scot
     
  2. LiNUxG0d

    LiNUxG0d Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gatineau, Quebec, Canada
    Hey Scot,

    WHM shouldn't have allowed it. A plus sign (+) is illegal in domain registration. You can't start domains with hyphens either, for example: -domain.com

    You could do: domain-domain.com but NOT domain+domain.com

    The only legal characters are indeed, a to z, 0 to 9 and hyphen.

    Warmest regards,
     
  3. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    WHM is wrong
     
  4. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    That's what I thought, thanks. I'll file a bug on this (a quick search of bugzilla... doesn't look like it's been filed before).
     
  5. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    It's an issue we are already aware of. It's simply not documented in Bugzilla.
     
  6. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    It's now bug #6485. Thanks.

    ./s
     
Loading...

Share This Page