The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I'm begging for someone to fix this

Discussion in 'General Discussion' started by danielaugustus, Mar 10, 2004.

  1. danielaugustus

    danielaugustus Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    I updated the kernel to 2.4.21-9.0.1.ELsmp.
    Update cPanel to latest Edge. I think E9.

    OS = RHE 3.0 ES

    Now my system has eximstats failing from time to time

    Apache failing from time to time

    even cpanel failed twice on about 4 hours.

    The system was not like this. I wont blame cpanel this time, maybe is some incompatibility with the new kernel. Maybe RedHat changed some stuff on the kernel. I dont know. What I can say is that we have this problem just on the machine with cPanel. the other where we are migrating to H-sphere ( well migrate most of our cpanel servers, as much as we could, unfortunaly the apache problem persists for more than 2 months, for customers one day is already innaceptable. ) is running fine, withou this kind of stuff.

    Maybe is some commands some cpanel core file use. I dont know. What I can SAY with SURe is that the apache problem is afeter receive a USR1 from cPanel.

    bdraco I want to apologyse about my last post about this problem. I was overhead. With more than 2000 phone calls on that day cause apache problems. Sorry ( of course werent I who answered, but my techs called me to ask what to say ).

    Well, I sincerally would love to have any comments from some cpanel staff about this.

    One thing I say, if it's not cpanel problem , it will be some incompatibility with cpanel and some new stuff on RHE 3.0 ES.

    After kernel upgrade thisn got worst.

    Well, any help would be needed.
     
  2. LordJMann

    LordJMann Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Does your machine have hyperthreading?
     
  3. danielaugustus

    danielaugustus Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Yes, It's a 2.8 HT machine.

    Well, the problem from CONSTANT apache hang was caused byt the kernel. But any kernel from redhat the apache hangs.

    more os less often, that's the difference just.

    Putting 2.6.3 now to try to see if gets better
     
  4. GrimReaper

    GrimReaper Active Member

    Joined:
    Jul 27, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Hi!

    Installing Kernel 2.6.3 doesn't help the problem (Well it didn't for me). After a week of this problem and a large loss of hair I found this article:

    https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=98333

    This basically tells you that there is a problem with the Operating System and Hyperthreading. If you have a good DC you can ask them nicely to turn it off for you in the boot loader.

    Fixed 90% of the problems I was having. I hope it helps here.

    Chris.
     
  5. danielaugustus

    danielaugustus Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    RedHat kernels stock + cpanel = system crash

    This happens on the last kernel o_0

    Trying to move to 2.6.4.... This fixed the most part of probems to a friend
     
  6. danielaugustus

    danielaugustus Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    2.6.4 every boot I got a kernel panic. It's like it does not find the /dev/sda3 where is the root.

    What to do ?
     

Share This Page