The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I'm giving up for now but the curiosity is killin me!

Discussion in 'General Discussion' started by ibanez0r, Apr 30, 2006.

  1. ibanez0r

    ibanez0r Member

    Joined:
    Apr 5, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Melbourne, AU
    Hi from sunny melbourne, australlia!

    Well I'm not sure where to start, after finding a couple of 'tried and tested' walk through's i decided to attempt setting up cpanel on FreeBSD v6-p7! Yes i know .. not supported and so on.. tho having a 5.4 box handy i thought screwit.. if i need to steal some old compat libs or which ever then i can do so fairly easily.!

    I installed a myriad of packages to _help_ the cpanel installer, and to my amazement, it worked just fine! I woke up *heh* and tried to login... YES it works@!!

    After going through the initial setup i realised oh damn! my QUOTA support had not been enabled in the systems fstab file.. so i did so.. rebooted and ... guess what.. no cpanel! hrmmph.. How could this be? it was up and running just fine only a matter of minutes ago!

    I used ldd to check the cpanel binary had all its required libs and soon realised that NO it didnt.. which made me wonder how could it of been running previously, according to ldd the cpanel binary in /usr/local/cpanel was missing libm.so.2 libc.so.4 and libcrypt.so.2 <- or something very close to that, instead of stealing teh required libs from my 5.4 box i thought id install ldconfig_compat and the compat4x and compat3x ports! compat3x is in broken state but i forced it anyways... After using ldconfig to rescan the lib paths and symlinking the missing libs to their newer counterparts.. the entire operating system died ! like ive never seen it do before.. huge amounts of missing functions and basically i cant use any of the binarys on that box! rebooting wont help.. I killed it!!! :(

    Now the box is being removed from the datacenter and my boss begrudginly is taking it back to the office to install v5.4 *hides*

    Just out of sheer curiosity is thre something i could of done to avoid this scenario, i will dead set cry my eyes out if you guys start supporting v6 any time in the near future!

    Yours Sincereley,
    Cameron James,
    CodeRED Gaming Australia
     
  2. cooldude7273

    cooldude7273 Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    363
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Roswell, GA
  3. astridas

    astridas Member

    Joined:
    Jun 20, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Did you compile a custom kernel with quota support before enabling quotas? Was only curious because I didn't see where you mentioned it.
     

Share This Page