bonjurkes

Member
Jul 3, 2005
22
0
151
Hello,

I am having ImageMagick problem and i already read

http://forums.cpanel.net/showthread.php?t=71234&highlight=Imagemagick

my problem is,

When i get my new server i tried to install Imagemagick, i didn`t know that it is already installed. When i realized it, i just give ./configure command to imagemagick installation.

Anyway,

Everything was fine till few days, i don`t really know what is the problem but, my scripts were working fine Imagemagick, but today i realized that there is a red x at Imagemagick

[[email protected] /]# /usr/bin/convert -version
Version: ImageMagick 6.2.6 12/19/07 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2006 ImageMagick Studio LLC


i look for mogrify folder and found it at /usr/bin/mogrify. but when i type the path it shows red x

And i can`t see imagemagick at phpinfo page also, i read that it can be because imagemagick is not compiled with php. I don`t know how to recompile php with imagemagick

Second question. the current version is 6.2.6 and the version i was going to install is 6.3.7.

Should i install new version, so it will overwrite old ones, will it fix my problem or how can i solve the problem?
 

Fernis

Well-Known Member
Oct 28, 2006
192
1
168
I also am having a similar issue and would like to know how to resolve it.
 

owine

Active Member
Jan 10, 2007
44
0
231
You have to install "imagick" in PECL from WHM -> Module Installers -> PECL
 

darren.nolan

Well-Known Member
Oct 4, 2007
257
0
66
When you compile apache, after you pick which versions of PHP you want, you can click on "advance settings" - opens up a great big page of all the funky mods to use for PHP - not juts the common ones of cURL etc.

When you recompile apache previously you've probably compiled PHP with default includes, using advance on your next apache build ensure that everything you had ticked (and now want included) is checked before continuing your build.

If it was working, you recompiled apache, and then it stopped - sounds like cPanel didn't keep your old build selections or you didn't specifically tell EA3 to use your old build settings.
 

owine

Active Member
Jan 10, 2007
44
0
231
Imagemagick support is not built by EasyApache. It must be added via PECL.
 

darren.nolan

Well-Known Member
Oct 4, 2007
257
0
66
I see, I just checked. I recall having to do that with GD/etc. etc.

I don't recall doing anything like mentioned above on my system :| I somehow have it installed...