Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

ImageMagik

Discussion in 'General Discussion' started by hyphyent, Feb 16, 2006.

  1. hyphyent

    hyphyent Member

    Joined:
    Jun 11, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    im trying to install the latest version of imnagemagik because im currently running ImageMagik.5.5.6 and i need to be running 6 or better inable for my AGS script to work.

    i downloaded the latest, untared it, configured it..when i ran make i get this error

    /usr/bin/ld: skipping incompatible /usr/X11R6/lib/libX11.so when searching for -lX11
    /usr/bin/ld: skipping incompatible /usr/X11R6/lib/libX11.a when searching for -lX11
    /usr/bin/ld: cannot find -lX11
    collect2: ld returned 1 exit status
    make: *** [magick/libMagick.la] Error 1
    make: Target `install' not remade because of errors.

    i did a search in the forums... i cam across

    http://forums.cpanel.net/showthread.php?t=45894&highlight=lX11

    in which case i used WHM and tried to force install the Xfree Dev package but it sait it was already installed

    so i downloaded XFree86-devel-4.3.0-97.EL.x86_64.rpm
    and rpm -Uvh --force XFree86-devel-4.3.0-97.EL.x86_64.rpm

    output:

    root@wsip-24-234-166-166 [/]# rpm -Uvh --force XFree86-devel-4.3.0-97.EL.x86_64.rpm
    warning: XFree86-devel-4.3.0-97.EL.x86_64.rpm: V3 DSA signature: NOKEY, key ID a7048f8d
    Preparing... ########################################### [100%]
    1:XFree86-devel ########################################### [100%]
    root@wsip-24-234-166-166 [/]#

    yet i tried to make ImageMagick and still get the same error

    /usr/bin/ld: skipping incompatible /usr/X11R6/lib/libX11.so when searching for -lX11
    /usr/bin/ld: skipping incompatible /usr/X11R6/lib/libX11.a when searching for -lX11
    /usr/bin/ld: cannot find -lX11
    collect2: ld returned 1 exit status
    make: *** [magick/libMagick.la] Error 1

    what am i not doing right
     
  2. hyphyent

    hyphyent Member

    Joined:
    Jun 11, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    anyone have any ideas?
     
  3. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    166
    I'm having similar issues (not with ImageMagick but with installing a separate PHP 5.1.2 installation) on CentOS 4.3 X86_64.

    Where did you get the RPMs?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice