The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

images not loading in advanced guestbook

Discussion in 'General Discussion' started by SilverMedia, Jul 19, 2007.

  1. SilverMedia

    SilverMedia Member

    Joined:
    Jul 19, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    HI I am wondering if someone can help me:

    I set up a advanced guestbook in Cpanel and for some reason it wount let me upload picture to it...

    I am getting an error like this
    Warning: move_uploaded_file(/home/wwwtpss/public_html/discuss/public/img-1184719668.jpg): failed to open stream: Permission denied in /home/wwwtpss/public_html/discuss/lib/add.class.php on line 172 Warning: move_uploaded_file(): Unable to move '/tmp/phpYlgm9t' to '/home/wwwtpss/public_html/discuss/public/img-1184719668.jpg' in /home/wwwtpss/public_html/discuss/lib/add.class.php on line 172 Warning: getimagesize(/home/wwwtpss/public_html/discuss/public/img-1184719668.jpg): failed to open stream: No such file or directory in /home/wwwtpss/public_html/discuss/lib/add.class.php on line 292 Guestbook Thank you for signing the guestbook. Your entry was added successfully! You should be transfered back to the guestbook in 2 seconds. Advanced Guestbook 2.4.2

    -I also changed permissions on the entire folder where guestbook resides to 777
    -basically my problem is that signing the guestbook adds the entry text but not the picture

    thanks in advance'd'
    Mark
     
  2. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    Check your php.ini to see if it has a valid upload_tmp_dir folder name. PHP will normally produce errors if upload_tmp_dir is not enabled and the folder not defined and if you have open_basedir enabled for the account.
     
  3. SilverMedia

    SilverMedia Member

    Joined:
    Jul 19, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    thanks that was fast...I think I figured it out...even though I changed permissions on the main folder for where the guestbook resides, I still had to individually change the permissions to 777 for the folder where the images are bieing sent and stored...

    thanks again
    Mark
     
Loading...

Share This Page