Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Images uploaded to website will not display properly

Discussion in 'General Discussion' started by vincentg, Aug 9, 2018.

  1. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    146
    Likes Received:
    3
    Trophy Points:
    168
    Location:
    new york
    Have a very strange problem

    Uploaded images will not display on a new website.
    I think images larger than a certain size is the problem but not sure as I uploaded a small jpg file and it worked but any other image I tried didn't.


    Images that will not display have a message that says "image cannot be displayed because it contains errors.

    Same images work on other sites

    checked apache conf and it's fine
    htaccess has nothing in it except deny from lines
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,204
    Likes Received:
    228
    Trophy Points:
    173
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @vincentg

    Can you please let us know if there are any errors reported in the PHP specific error logs or the Apache error logs?

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    146
    Likes Received:
    3
    Trophy Points:
    168
    Location:
    new york
    Wish it was that simple.
    It has nothing to do with PHP or perl or any other language.
    Nothing to do with settings as it has the default settings.
    Nothing to do with Mod Security - using Comodo for that.
    Even if you view the image from the URL it will not display but we found out something.
    In further checking I found out that if I make the image smaller in size it will show.
    The cure it seems is not to name it logo
    If logo is anywhere in the name it will not display.
    Call it something else and no problem.
    This happens in any browser used as I tried four of the 5 on my PC - Firefox - Opera - Edge - Chrome

    What is up with logo?
    I can't name a file logo.jpg?
    Is this some new browser thing?
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,480
    Likes Received:
    421
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might try another browser, or disable your adblocking addon to see if that helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    146
    Likes Received:
    3
    Trophy Points:
    168
    Location:
    new york
    Here's where it gets stranger
    The same logo.jpg image works fine when uploaded to another website on the same server.
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,480
    Likes Received:
    421
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you asked your Hosting Provider about this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice