Images uploaded to website will not display properly

vincentg

Well-Known Member
May 12, 2004
154
3
168
new york
Have a very strange problem

Uploaded images will not display on a new website.
I think images larger than a certain size is the problem but not sure as I uploaded a small jpg file and it worked but any other image I tried didn't.


Images that will not display have a message that says "image cannot be displayed because it contains errors.

Same images work on other sites

checked apache conf and it's fine
htaccess has nothing in it except deny from lines
 

vincentg

Well-Known Member
May 12, 2004
154
3
168
new york
Hi @vincentg

Can you please let us know if there are any errors reported in the PHP specific error logs or the Apache error logs?

Thanks!
Wish it was that simple.
It has nothing to do with PHP or perl or any other language.
Nothing to do with settings as it has the default settings.
Nothing to do with Mod Security - using Comodo for that.
Even if you view the image from the URL it will not display but we found out something.
In further checking I found out that if I make the image smaller in size it will show.
The cure it seems is not to name it logo
If logo is anywhere in the name it will not display.
Call it something else and no problem.
This happens in any browser used as I tried four of the 5 on my PC - Firefox - Opera - Edge - Chrome

What is up with logo?
I can't name a file logo.jpg?
Is this some new browser thing?
 

vincentg

Well-Known Member
May 12, 2004
154
3
168
new york
Here's where it gets stranger
The same logo.jpg image works fine when uploaded to another website on the same server.