The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Imagick 5.5.7

Discussion in 'General Discussion' started by M@RS, Feb 19, 2004.

  1. M@RS

    M@RS Registered

    Joined:
    Feb 19, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I have a big problem
    This month we switched servers and from that point imagick gives big problems with our scripts

    This is the error we got:

    A FATAL CGI ERROR HAS OCCURRED
    ==============================
    Error Message : Exception 430: UnableToOpenFile ()
    Accessing File : /home/dws/public_html/thumbs/D554967F-1076888123.jpg
    Running as User : nobody
    Running as Group : nobody

    The folder is CHMOD 777

    i looked at the old server and there was imagick 5.5.7 installed (also whm/cpanel)

    So i asked to install 5.5.7 on our new server:
    This is the answer of my new host:

    apologize, but our Systems Administrators have informed me that installing this module to your server at this point isn't possible. We've attempted the install of ImageMagick 5.5.7 with PERL, but it just won't compile correctly. If you would like to contact cpanel.net, they may be able to help you out with this. You can always post questions and such to http://forums.cpanel.net, also.

    so big problem for us :-(

    I asked also the creators of the script that uses imagick and they say:

    We recommend the latest version of ImageMagick, 5.5.7, and we also highly recommend that it be compiled from source code rather than installing a pre-compiled binary version.

    We need imagick for: Auto gallerie SQL and PRO (http://www.jmbsoft.com/software/ags/)

    Hopefully somebody can help
     
  2. M@RS

    M@RS Registered

    Joined:
    Feb 19, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Nobody?? :(
     
  3. Roy@ENHOST

    Roy@ENHOST Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    495
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Los Angeles California
    I have sent you a private message.
    Telling you Imagemagick installation has nothing to do with Cpanel.
     
  4. M@RS

    M@RS Registered

    Joined:
    Feb 19, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thank you very much for your reply :)
     
  5. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Would that mean the problem is now solved?

    BTW, although Cpanel installs ImageMagick 5.4.3 (last I heard anyway) which may not be the latest & greatest, it does the job quite nicely.
     
  6. M@RS

    M@RS Registered

    Joined:
    Feb 19, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    No it did not help to solve my problem
    we need 5.5.7
    There is something wrong with permagic becasue the version on the server is 5.5.7
    but if you download perlmagick then it seems to be corrupt!
    When everythjing is working again i will post a solution here
     
  7. Roy@ENHOST

    Roy@ENHOST Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    495
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Los Angeles California
    Why don't you get your host to install it manually instead of going through Cpanel? It is not a lot of work anyway.
     
Loading...

Share This Page