The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

imap and mail mx entry

Discussion in 'E-mail Discussions' started by Networkologist, Mar 7, 2003.

  1. Networkologist

    Networkologist Well-Known Member

    Joined:
    Feb 5, 2003
    Messages:
    209
    Likes Received:
    0
    Trophy Points:
    16
    I just had cpanel re-installed and now I'm getting imap errors. There is no entry in the 'mail' domain in WHM under the "edit an mx entry". I'm not sure what should be there.


    Mar 7 13:26:03 secure xinetd[24495]: Server imapd is not executable [line=8] Mar 7 13:27:01 secure xinetd[25582]: Server
    imapd is not executable [line=8] Mar 7 13:35:30 secure xinetd[25719]: Server imapd is not executable [line=8] Mar 7
    13:44:00 secure xinetd[25837]: Server imapd is not executable [line=8] Mar 7 13:52:29 secure xinetd[25992]: Server imapd is
    not executable [line=8] Mar 7 14:00:58 secure xinetd[26126]: Server imapd is not executable [line=8] Mar 7 14:09:27 secure
    xinetd[26237]: Server imapd is not executable [line=8] Mar 7 14:17:57 secure xinetd[26605]: Server imapd is not executable
    [line=8] Mar 7 14:20:03 secure xinetd[26711]: Server imapd is not executable [line=8] imap has failed, please contact the
    sysadmin.
     
  2. Networkologist

    Networkologist Well-Known Member

    Joined:
    Feb 5, 2003
    Messages:
    209
    Likes Received:
    0
    Trophy Points:
    16
    BTW

    I did try Annettes fix, but its still failing.

    /etc/rc.d/init.d/portsentry stop
    restart imap
    /etc/rc.d/init.d/portsentry start
    You may need to restart xinetd as the second step if the above does not allow imap to restart:
    /etc/rc.d/init.d/xinetd restart
     
  3. Networkologist

    Networkologist Well-Known Member

    Joined:
    Feb 5, 2003
    Messages:
    209
    Likes Received:
    0
    Trophy Points:
    16
  4. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    What's the output of this?

    # cat /etc/xinetd.d/cpimap
     
  5. Networkologist

    Networkologist Well-Known Member

    Joined:
    Feb 5, 2003
    Messages:
    209
    Likes Received:
    0
    Trophy Points:
    16
    # Converted by inetdconvert
    service imap
    {
    socket_type = stream
    protocol = tcp
    wait = no
    user = root
    server = imapd
    disable = no
    }
    root@secure [/etc/xinetd.d]#

    And a stat of usr/sbin/imapd

    File: "imapd"
    Size: 1519222 Blocks: 2976 IO Block: 4096 Regular File
    Device: 302h/770d Inode: 360558 Links: 1
    Access: (0755/-rwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
    Access: Fri Mar 7 13:18:37 2003
    Modify: Tue Mar 4 14:18:14 2003
    Change: Tue Mar 4 14:18:14 2003
     
  6. Networkologist

    Networkologist Well-Known Member

    Joined:
    Feb 5, 2003
    Messages:
    209
    Likes Received:
    0
    Trophy Points:
    16
    Still wondering, tho...

    I took screen shots of my setup before the new license was installed, just in case. Everything but the "mail" zone. Currently that zone doesn't have an entry and I'm not sure what it should be.
     
  7. Networkologist

    Networkologist Well-Known Member

    Joined:
    Feb 5, 2003
    Messages:
    209
    Likes Received:
    0
    Trophy Points:
    16
    This fixed it

    From a response I received on WHT:

    Take a look in the '/etc/xinetd.d' folder, then see if there is an 'imap' file or a 'cpimap' file. Open whichever one that is there and check the 'server' line, change it to '/usr/sbin/imapd'. Save the file and restart xinetd.
    The above is only a suggestion, but if you have "server = imapd", then changing it to /usr/sbin/imapd should make it work.

    Now, my question is, will this be overwritten by any updates, etc?
     
  8. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    I had the same problem after reinstalling Cpanel on a new box. Then I upgraded to the latest version and that fixed the problem.
     
  9. Finkinstein

    Finkinstein Well-Known Member

    Joined:
    Mar 21, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    What if I have both? Should I? I am wondering if they are purhaps conflicting.... I can't get IMAP to open the stream.
     
Loading...

Share This Page