The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IMAP Autoconfig and Main Server SSL

Discussion in 'E-mail Discussions' started by TCB13, Sep 16, 2014.

  1. TCB13

    TCB13 Well-Known Member

    Joined:
    Jul 25, 2014
    Messages:
    58
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hello,

    This question might be already posted by someone, but I couldn't find it, so sorry in advance for a report.

    Here is the problem, people usually try to use autoconfig on their email clients to get the IMAP/SMTP configured but by some reason cPanel or the client usually mess up when it comes to the server secure address.

    On all servers I've a valid SSL certificate as the server hostname that can be used for email and everything works fine, however the email clients (probably to autoconfig) always choose the client domain (something like mail.clientdomain.com) instead of the server hostname, resulting in SSL errors like certificate mismatch.

    Is this fixable at WHM? If yes, how? How can I force email clients to always auto configure with the server hostname? So they can take advantage of a valid SSL certificate...

    Thank you.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It should use the SSL certificate name configured for the service in:

    "WHM Home » Service Configuration » Manage Service SSL Certificates"

    Thank you.
     
  3. TCB13

    TCB13 Well-Known Member

    Joined:
    Jul 25, 2014
    Messages:
    58
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    It uses that certificate the problem is that the certificate is for the hostname of the server, and email client always configure with the domain of the cpanel, and the we get a certificate mismatch error.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you clarify what you mean here? You mentioned it uses that certificate, but yet it's configured with the domain name of the account. Do you mean it does not use the certificate name for SSL in the automatic configuration settings? If not, please open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. TCB13

    TCB13 Well-Known Member

    Joined:
    Jul 25, 2014
    Messages:
    58
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Let't take the address test@mydomain.com as an example, If I enter that into some mail clients they configure the account with:

    IMAP Server: mail.mydomain.com
    SSL Enabled: yes

    mydomain.com is the domain for the cPanel account owning that email account, and it does not have an SSL certificate.

    The server itself, server1.company.net, has a valid SSL certificate installed and I can see it at "WHM Home » Service Configuration » Manage Service SSL Certificates".

    Everytime the user tries to access the email he gets a message saying that the certificate provided by the server if for the domain server1.company.net and not for mail.mydomain.com.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, that is the normal behavior (See This Feature Request). You wrote:

    That leads me to believe this only happens when manually entering the mail server details. Your initial post lead me to believe that information was suggested for use in cPanel under the "Configure Email Client" option.

    Thank you.
     
  7. TCB13

    TCB13 Well-Known Member

    Joined:
    Jul 25, 2014
    Messages:
    58
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Sorry about the confusion, yes this happens when I try to configure the email client by providing the email address, not via cPanel "Configure Email Client" option.

    Why this happens? The email client should get the server hostname so it won't result in SSL errors.
    The feature request you suggested will allow my clients to add SSL certificated for their domains, however, the thing I want is auto discover (or something similar) to foce the server hostname into the email client.

    Thank you.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please ensure the following option is enabled under the "Domains" tab in "WHM Home » Server Configuration » Tweak Settings":

    "Thunderbird and Outlook autodiscover and autoconfig support (enables proxy subdomain and SRV record creation)"

    Also, you can update "Host to publish in the SRV records for Outlook autodiscover support." to your SSL host if you prefer. Documentation on this topic is available at:

    AutoConfig and AutoDiscover

    Thank you.
     
Loading...

Share This Page