IMAP connecting not working on Windows, does on mobile and MAC

Operating System & Version
CentOS v7.9.2009 STANDARD standard
cPanel & WHM Version
106.0.9

PieterVH

Registered
Nov 7, 2022
1
0
1
Netherlands
cPanel Access Level
Root Administrator
Hi There,

My old server got corrupted after a restart (all was working before), so I took a new dedicated server to move all my 96 accounts. Server managers dit that for me. So far all good. Now people with windows computers start complaining the mail can't connect (tried with Thunderbird, and Outlook) with their mail accounts.

Mac mail: connects within a second
Outlook Mac: connects within a second
Outlook iPhone: connects within a second.
Webmail: works like a charm.

DNS records are good (e-mail deliverabillity tab gives a checkmark)
I restarted IMAP server and mailing server several times.

My server guys say nothing is odd and it can't be something in the new WHM configuration. I thought of IP bans, but the logs are clean. Is there anyone who has a clue of what might be happening here?
 

Attachments

Last edited by a moderator:

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
542
253
138
IN
cPanel Access Level
Root Administrator
Try to change the incoming server settings as below:

Code:
Port: 993 or 143
Connection Security: Auto
 
  • Like
Reactions: cPRex

ITHKBO

Active Member
Jun 23, 2020
28
31
13
Netherlands
cPanel Access Level
Root Administrator
It sounds like it might be a issue related to TLS protocol versions active on the Windows clients *if the firewall and cPHulk Bruteforce Protection is not showing anything*.

Can you crosscheck what TLS and ciphers are allowed on the server in EXIM and one of the problematic clients?
Exim Configuration Manager-> Basic Editor -> Security -> Options for Open SSL
Should read something like this: +no_sslv2 +no_sslv3 +no_tlsv1 +no_tlsv1_1

To check on Windows we use IIS Crypto as powershell is a pain with this kind of audit.

Always be wary with executables and do your own research for safety.
I have done a quickscan for you with the latest version


We have had past cases with Windows Message User Agents (MUA's) trying the connection with a lower version than allowed by our servers causing connection issues without a clear error in MUA. This in turn required us to monitor live port access on the mail server. After some time we found out some Windows clients used TLS1.0 or 1.1 to connect which are considered End of Life (EOL) disabling the protocols on the Windows client with a restart solved that issue.

Be sure to verify that no legacy software still requires any EOL protocol before disabling its functionality.
 
  • Like
Reactions: martin MHC

martin MHC

Well-Known Member
Sep 14, 2016
317
71
78
UK
cPanel Access Level
Root Administrator
We have a very similar issue this morning; it appears that a MS Outlook update (I assume) has caused Outlook to somehow mess up displaying data to the customer. We have logs on the server that emails are received by the mailbox and that Outlook connects ok to the server, but Outlook internally doesn't display these emails to the client.