The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Imap failing

Discussion in 'General Discussion' started by psychodreams, Apr 27, 2004.

  1. psychodreams

    psychodreams Well-Known Member

    Joined:
    Apr 14, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    i am having a problem with imap failing
    possible due to a change in the xinitd.conf file and in the /etc/init.d/services file i was trying to get something to work from a post then noticed it made the imap fail. i changed the files back to what they were and still having the problem does someone have a solution or a copy of these 2 files that i could possibly try to get to work

    this is the error im getting in the messages file

    Apr 27 08:44:37 server pure-ftpd[2756]: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Apr 27 08:44:37 server pure-ftpd[2756]: (?@127.0.0.1) [INFO] Logout - CPU time spent: 0.000 seconds.
    Apr 27 08:44:37 server xinetd: xinetd shutdown failed
    Apr 27 08:44:37 server xinetd[2781]: missing service keyword [line=6]
    Apr 27 08:44:37 server xinetd[2781]: Unable to read included directory: /etc/xinetd.d^M [line=16]
    Apr 27 08:44:37 server xinetd[2781]: xinetd Version 2.3.11 started with libwrap loadavg options compiled in.
    Apr 27 08:44:37 server xinetd[2781]: Started working: 0 available services
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    1. Make sure that you don't define imap in /etc/xinetd.conf and that the last line of that file is:

    includedir /etc/xinetd.d

    2. go to /etc/xinetd.d and you need a file called cpimap which contains:
    Code:
    # default: off
    # description: imapd
    service imap
    {
            socket_type             = stream
            wait                    = no
            user                    = root
            server                  = /usr/sbin/imapd
            disable                 = no
    }
    
    If you found a problem and the above was done, restart xinetd:
    /etc/init.d/xinetd restart
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    One more thing if you still have trouble after that:

    1. Make sure there are no other files other than cpimap that comtain a definition for "service imap". If there are, delete them.

    2. Check that imap is defined in your /etc/services file:
    Code:
    # grep 143/ /etc/services
    imap            143/tcp         imap2           # Interim Mail Access Proto v2
    imap            143/udp         imap2
    
     
  4. psychodreams

    psychodreams Well-Known Member

    Joined:
    Apr 14, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    No Luck

    I checked everything you posted all is exactly the same so no luck

    get this though
    xinetd dead but pid file exists
     
  5. psychodreams

    psychodreams Well-Known Member

    Joined:
    Apr 14, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    Get This

    Apr 27 14:11:07 server xinetd: xinetd shutdown failed
    Apr 27 14:11:07 server xinetd[23529]: missing service keyword [line=6]
    Apr 27 14:11:07 server xinetd[23529]: Server in.ntalkd is not executable [line=8]
    Apr 27 14:11:07 server xinetd[23529]: Error parsing attribute server - DISABLING SERVICE [line=8]
    Apr 27 14:11:07 server xinetd[23529]: Server in.qpopper is not executable [line=8]
    Apr 27 14:11:07 server xinetd[23529]: Error parsing attribute server - DISABLING SERVICE [line=8]
    Apr 27 14:11:07 server xinetd[23529]: missing service keyword [line=22]
    Apr 27 14:11:07 server xinetd[23529]: missing } in last service entry [line=569]
    Apr 27 14:11:07 server xinetd[23529]: 23529 {general_handler} (23529) Unexpected signal: 11 (Segmentation fault)
    Apr 27 14:11:07 server last message repeated 9 times
    Apr 27 14:11:07 server xinetd[23529]: 23529 {bad_signal} Received 10 signals in 1 seconds. Exiting...
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you do:

    /etc/init.d/xinetd stop

    Then check ps -axf and make sure it isn't running. If it is still, do a:

    kill -9 PID

    Where PID is the pid of the process running xinetd

    Once you're sure it is dead, check for the file:

    /var/lock/subsys/xinetd

    It that file exists, delete it. Then try starting xinetd again:

    /etc/init.d/xinetd start
     
  7. psychodreams

    psychodreams Well-Known Member

    Joined:
    Apr 14, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    Tried that

    No luck Tried that
     
  8. ksingh

    ksingh Active Member

    Joined:
    Mar 21, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    I am also facing similar problem. Tried everything mentioned in this forum. One interesting thing. After restarting xinetd, if I do
    telnet localhost 143

    this messages pops up

    Trying <IP>...
    Connected to <domain>
    Escape character is '^]'.
    * BYE Service not available <hostname>
    IMAP4rev1 2001.315rh at Wed, 5 May 2004 14:06:34 +0530 (IST)
    Connection closed by foreign host.


    Any clues?

    K Singh
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I've done some searching on this:

    Check whether you have a file called:

    /etc/nologin

    If you do, this tells imap to drop any new connections. try deleting it.
     
  10. ksingh

    ksingh Active Member

    Joined:
    Mar 21, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Hello chirpy,

    It worked. Thanks a million.

    K Singh
     
  11. PondRicefied

    PondRicefied Well-Known Member

    Joined:
    Dec 13, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    I also have the almost same error.

    I also have the almost same error.
    I have set so that only cpimap may be started.
    but, cpimap is not running.

    > /etc/init.d/xinetd stop
    > Then check ps -axf and make sure it isn't running. If it is still, do a:
    > kill -9 PID
    xinetd process is not exist.

    > Once you're sure it is dead, check for the file:
    > /var/lock/subsys/xinetd
    I deleted.
    > /etc/init.d/xinetd start
    cpimap is not running.

    /etc/nologin is no such file and directory.

    As natural,
    % telnet localhost 143
    -----------------------------------------------------
    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    -----------------------------------------------------

    Why doesn't it run?

    Below, I describe the content of a setting, and a log.


    xinetd log.
    -----------------------------------------------------
    Jan 9 18:18:17 sv1 xinetd[27213]: {Other DISABLING SERVICE's log}
    Jan 9 18:18:17 sv1 xinetd: xinetd 起動 succeeded
    Jan 9 18:18:17 sv1 xinetd[27213]: 27213 {general_handler} (27213) Unexpected signal: 11 (Segmentation fault)
    Jan 9 18:18:17 sv1 last message repeated 9 times
    Jan 9 18:18:17 sv1 xinetd[27213]: 27213 {bad_signal} Received 10 signals in 1 seconds. Exiting...
    -----------------------------------------------------

    % cat xinetd.d/cpimap
    -----------------------------------------------------
    # default: off
    # description: imapd
    service imap
    {
    socket_type = stream
    wait = no
    user = root
    # server = /usr/local/cpanel/3rdparty/bin/imapd
    server = /usr/sbin/in.imapd
    disable = no
    }
    -----------------------------------------------------

    % ls -ld /usr/sbin/in.imapd
    -----------------------------------------------------
    lrwxrwxrwx 1 root root 36 Jan 9 16:45 /usr/sbin/in.imapd -> /usr/local/cpanel/3rdparty/bin/imapd
    -----------------------------------------------------

    % ldd /usr/sbin/in.imapd
    -----------------------------------------------------
    /lib/libsafe.so.2 => /lib/libsafe.so.2 (0x0096f000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0x001b5000)
    libc.so.6 => /lib/tls/libc.so.6 (0x001e3000)
    libdl.so.2 => /lib/libdl.so.2 (0x00301000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x4712d000)
    -----------------------------------------------------

    % execstack -q /usr/sbin/in.imapd
    -----------------------------------------------------
    ? /usr/sbin/in.imapd
    -----------------------------------------------------
    I tested,
    % execstack -s /usr/sbin/in.imapd
    execstack -c /usr/sbin/in.imapd
    -----------------------------------------------------
    execstack: /usr/sbin/in.imapd: Reshuffling of objects to make room for
    program header entry only supported for shared libraries
    -----------------------------------------------------
     
    #11 PondRicefied, Jan 9, 2005
    Last edited: Jan 9, 2005
  12. Piggers

    Piggers Member

    Joined:
    Nov 14, 2003
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    0
    Actually I fixed mine by changing my version to current and then updating cpanel. After update was complete. Walla! It works!
     
  13. etromania

    etromania Registered

    Joined:
    Sep 7, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Not if it will help, I was having the same issue, Mine was I had entered ALL:ALL in the hosts.deny file to aid in stoping the random attempts of logins on my server
     
Loading...

Share This Page