imap has failed, please contact the sysadmin result was couriertcpd is not running

PHP Warner

Member
Aug 6, 2006
23
0
151
I've a problen when I attempting to restart imap.

Waiting for imap to restart.... . . . . . . . . . . finished.

imap status

imap has failed, please contact the sysadmin (result was "couriertcpd is not runningauthdaemond is not running").

I've try to /scripts/courierup --force but it is giving the error below:

creating libmaildir.la
(cd .libs && rm -f libmaildir.la && ln -s ../libmaildir.la libmaildir.la)
cc -DHAVE_CONFIG_H -I. -I/usr/local/include -I/usr/local/include -O2 -fno-strict-aliasing -pipe -Wall -I./.. -I.. -MT deliverquota.o -MD -MP -MF .deps/deliverquota.Tpo -c -o deliverquota.o deliverquota.c
mv -f .deps/deliverquota.Tpo .deps/deliverquota.Po
/bin/sh ./libtool --tag=CC --mode=link cc -O2 -fno-strict-aliasing -pipe -Wall -I./.. -I.. -static -L/usr/local/lib -L/usr/local/lib -rpath=/usr/local/lib -o deliverquota deliverquota.o libmaildir.la ../rfc822/librfc822.la ../numlib/libnumlib.la
cc -O2 -fno-strict-aliasing -pipe -Wall -I./.. -I.. -rpath=/usr/local/lib -o deliverquota deliverquota.o -L/usr/local/lib ./.libs/libmaildir.a ../rfc822/.libs/librfc822.a ../numlib/.libs/libnumlib.a
cc -DHAVE_CONFIG_H -I. -I/usr/local/include -I/usr/local/include -O2 -fno-strict-aliasing -pipe -Wall -I./.. -I.. -MT maildirmake.o -MD -MP -MF .deps/maildirmake.Tpo -c -o maildirmake.o maildirmake.c
mv -f .deps/maildirmake.Tpo .deps/maildirmake.Po
/bin/sh ./libtool --tag=CC --mode=link cc -O2 -fno-strict-aliasing -pipe -Wall -I./.. -I.. -static -L/usr/local/lib -L/usr/local/lib -rpath=/usr/local/lib -o maildirmake maildirmake.o libmaildir.la ../numlib/libnumlib.la ../rfc822/librfc822.la
cc -O2 -fno-strict-aliasing -pipe -Wall -I./.. -I.. -rpath=/usr/local/lib -o maildirmake maildirmake.o -L/usr/local/lib ./.libs/libmaildir.a ../numlib/.libs/libnumlib.a ../rfc822/.libs/librfc822.a
cc -DHAVE_CONFIG_H -I. -I/usr/local/include -I/usr/local/include -O2 -fno-strict-aliasing -pipe -Wall -I./.. -I.. -MT testmaildirfilter.o -MD -MP -MF .deps/testmaildirfilter.Tpo -c -o testmaildirfilter.o testmaildirfilter.c
mv -f .deps/testmaildirfilter.Tpo .deps/testmaildirfilter.Po
/bin/sh ./libtool --tag=CC --mode=link cc -O2 -fno-strict-aliasing -pipe -Wall -I./.. -I.. -static -L/usr/local/lib -L/usr/local/lib -rpath=/usr/local/lib -o testmaildirfilter testmaildirfilter.o libmaildir.la ../numlib/libnumlib.la -lpcre
cc -O2 -fno-strict-aliasing -pipe -Wall -I./.. -I.. -rpath=/usr/local/lib -o testmaildirfilter testmaildirfilter.o -L/usr/local/lib ./.libs/libmaildir.a ../numlib/.libs/libnumlib.a /usr/local/lib/libpcre.so -Wl,--rpath -Wl,/usr/local/lib -Wl,--rpath -Wl,/usr/local/lib
/usr/local/lib/libpcre.so: undefined reference to `__sbtolower'
/usr/local/lib/libpcre.so: undefined reference to `__sbmaskrune'
/usr/local/lib/libpcre.so: undefined reference to `__sbtoupper'
gmake[3]: *** [testmaildirfilter] Error 1
gmake[3]: Leaving directory `/usr/ports/mail/courier-imap/work/courier-imap-4.2.1/maildir'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/mail/courier-imap/work/courier-imap-4.2.1/maildir'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/mail/courier-imap/work/courier-imap-4.2.1'
gmake: *** [all] Error 2
*** Error code 2

Operating system is freebsd 6.2, any advice for fix this problem?