WebmasterAJ

Registered
Jan 11, 2003
3
0
151
Hello everyone, I am extremely new at this... but I've searched the boards and I really didn't see anything that solved my problem.

In WHM, when I attempt to restart IMAP I get the following error:
Jan 9 15:24:07 dolphins xinetd[4632]: Server imapd is not executable [line=8] Jan 9 16:40:22 dolphins xinetd[868]: Server imapd is not executable [line=8] Jan 11 12:37:50 dolphins xinetd[16700]: Server imapd is not executable [line=8] Jan 11 13:48:19 dolphins xinetd[19344]: Server imapd is not executable [line=8] Jan 11 15:12:09 dolphins xinetd[23226]: Server imapd is not executable [line=8] Jan 11 15:38:40 dolphins xinetd[24619]: Server imapd is not executable [line=8] Jan 11 16:05:56 dolphins xinetd[25966]: Server imapd is not executable [line=8] Jan 11 18:30:13 dolphins xinetd[30962]: Server imapd is not executable [line=8] Jan 11 21:34:33 dolphins xinetd[3045]: Server imapd is not executable [line=8] Jan 11 21:43:37 dolphins xinetd[3383]: Server imapd is not executable [line=8] Jan 11 21:44:37 dolphins xinetd[3504]: Server imapd is not executable [line=8] Jan 11 21:49:05 dolphins xinetd[3504]: Server imapd is not executable [line=8] Jan 11 21:49:18 dolphins xinetd[3739]: Server imapd is not executable [line=8] imap has failed, please contact the sysadmin.


I have already reinstalled IMAP and I have restarted /etc/rc.d/init.d/portsentry

Also, I hope this is the problem that is causing me not to receive emails. For example, I can send email from [email protected], however, I can not receive email. When I go to &Manage Mail Queue& I see all my mail that I'm supposed to receive... if I click &deliver now& I also get this message:

Message 18XY72-0000tO-00 is not frozen
delivering message 18XY72-0000tO-00
LOG: 0 MAIN
== [email protected] T=virtual_sa_userdelivery defer (32): Broken pipe: error while writing to /home/fhco/mail/finheaven.com/webmaster/inbox
Return to Mail Queue

For that problem, I have also ran /scripts/mailperm... but again... no luck.

Anyways, if anyone could PLEASE help me out, I'll really really appreciate it.

Again, thank you for your time and energy...

Sincerely,
Andrew Tatum

EDIT: Also, here are the versions:
WHM 5.3.0
Cpanel 5.3.0-R117
 

WebmasterAJ

Registered
Jan 11, 2003
3
0
151
Sorry, but does anyone have any clues as to why I am receiving this error?

Thank you for your time and energy...
 

steven

Active Member
Sep 9, 2001
39
0
306
Is imap working on any other accounts on the server? Maybe you just need to click on the mail troubleshooter option in the root WHM for that email addy.

-Steven
 

WebmasterAJ

Registered
Jan 11, 2003
3
0
151
No other email address is working, and when I try the mail trouble shooter it simply tells me...

&Sorry, I couldn't find a problem.. maybe I just don't know about
the problem you are having or there is no problem&

Thanks for your assistance, I really appreciate it.

Andrew
 

Snowman

Member
Sep 9, 2002
14
0
151
I am getting the same errors on a server with

WHM 5.3.0
Cpanel 5.3.0-R117

anyone have any ideas???

or is there a way to diable IMAP so it doesnt keep trying to restart itself every 10 minutes.
 

Clay

Member
Jan 16, 2003
20
0
151
I removed the imap file from /var/run/chkservd and it no longer lists it in the server status...
 

Clay

Member
Jan 16, 2003
20
0
151
[quote:3dee16a036][i:3dee16a036]Originally posted by Clay[/i:3dee16a036]

I removed the imap file from /var/run/chkservd and it no longer lists it in the server status...[/quote:3dee16a036]

well, that worked until soemthing else put the file back in.
 

dgbaker

Well-Known Member
PartnerNOC
Sep 20, 2002
2,576
9
343
Toronto, Ontario Canada
cPanel Access Level
DataCenter Provider
[quote:ee59641001][i:ee59641001]Originally posted by Clay[/i:ee59641001]

[quote:ee59641001][i:ee59641001]Originally posted by Clay[/i:ee59641001]

I removed the imap file from /var/run/chkservd and it no longer lists it in the server status...[/quote:ee59641001]

well, that worked until soemthing else put the file back in.[/quote:ee59641001]

That's because that's not the main file. If you want to remove it completly then you also need to remove /etc/chkserv.d/imap
then restart chkservd daemon.
 

shaun

Well-Known Member
PartnerNOC
Verifed Vendor
Nov 9, 2001
708
1
318
San Clemente, Ca
cPanel Access Level
DataCenter Provider
Twitter
rpm -e --nodeps imap
rpm -e ---nodeps imap-devel
/scripts/installrpm imap
/scripts/installrpm imap-devel
cp /usr/local/cpanel/bin/cpimap /usr/sbin/imapd

check the /etc/xinetd.d/cpimap file (some times it's named imap or imapd) and make sure disable = no

then /etc/init.d/xinetd restart


This shoudl make imap work.
 

jsteel

Well-Known Member
Jul 4, 2002
646
0
166
Atlanta, GA
Based on the the first post, I see it keeps repeating:

"Server imapd is not executable"

Have any of you checked to see if the imapd file has execute privileges? If it doesn't, chmod it and then see what happens.

Jaz
 

rcthost

Active Member
Sep 16, 2002
44
0
156
I was able to fix mine from getting that error message by deleting the mail queue, however I do not know if that fixed my clients email problem.