imap/pop3 fail after last update

karlos

Member
Oct 1, 2003
17
0
151
Hello,

after last night CPanel update, imap and pop3 service cannot start.

When I go to WHM Main >> Restart Services >> IMAP Server I get this error

Code:
imap has failed, please contact the sysadmin (result was "couriertcpd is not runningauthdaemond is not running").
I try with /scripts/courierup --force and get the same error

Code:
Waiting for cppop to shutdown ... ...Done
Waiting for cppop-ssl to shutdown ... ...Done
Waiting for imap to restart..............finished.


imap has failed, please contact the sysadmin (result was "couriertcpd is not runningauthdaemond is not running").
Install Complete
[email protected] [~]#
And get some core files too with this error

Code:
Loaded system supplied DSO at 0x380000
Core was generated by `/usr/sbin/courierlogger -pid=/var/spool/authdaemon/pid -facility=mail -start /u'.
Program terminated with signal 8, Arithmetic exception.
I try with

Code:
[~]# /etc/init.d/courier-authlib start
Starting Courier authentication services:/etc/init.d/courier-authlib: line 19: 31977 Floating point exception(core dumped) $sbindir/authdaemond start
 authdaemond
but nothing.


:confused: How can I fix this kind of error?


Some data about the server

WHM 11.15.0 cPanel 11.18.5-S23897
FEDORA 7 i686 on standard - WHM X v3.1.0

Linux 2.6.17-1.2142_FC4smp #1 SMP Tue Jul 11 22:57:02 EDT 2006 i686 i686 i386 GNU/Linux

Thanks,

Karlos

p.d.: I submit a support ticket without response
 

karlos

Member
Oct 1, 2003
17
0
151
Well, finally the cpanel support team answered my ticket and fix the problem installing an older courier RPM.

The problem was that the actual version installed of courier isn't compatible with my actual server configuration which is too old. I need to upgrade kernel and other system files before run newer version of courier-imap.

Regards,
Karlos
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
77
308
cPanel Access Level
Root Administrator
Well, finally the cpanel support team answered my ticket and fix the problem installing an older courier RPM.

The problem was that the actual version installed of courier isn't compatible with my actual server configuration which is too old. I need to upgrade kernel and other system files before run newer version of courier-imap.

Regards,
Karlos
Did you perchance upgrade to Fedora 7 from a prior version of Fedora?