IMAP service keeps failing and restarting

consultorpc

Well-Known Member
PartnerNOC
Jun 18, 2003
51
0
156
Look if your date is the same as hwclock, we had issues with one server with this error.
 

formula13x

Member
Nov 25, 2008
9
0
51
I am fighting this problem too.. But mine is much worse (about 40 times a day).
It started a few weeks ago. I am on a VPS. Any more things to try? Also, what were you talking about with the hwclock?

the authdaemon instances just keep dying.. Is there anything I can do to debug it to see why they are dying so quickly? I've upped them to 10.
 
Last edited:

formula13x

Member
Nov 25, 2008
9
0
51
Here is a hack, just to keep it working I suppose.
I don't like doing this, and want a real solution not a hack.
But anyhow.
I just created a script named watchauthdaemond.sh
as

#!/bin/bash
if test `ps -elf|grep authdaemond|wc -l` -lt 2
then
authdaemond stop
authdaemond start
fi


Then I created a created an entry in my crontab to make it run every minute

* * * * * /scripts/watchauthdaemond.sh > /dev/null 2>&1

We'll see if it works for the time being.

Any real solution would be greatly appreciated.
 
Last edited:

jols

Well-Known Member
Mar 13, 2004
1,107
3
168
Hi, I've increased the number of auth daemons from 2 to 5 this week and there are still login problems. I've reinstalled exim and courier and the problem is still there. Any idea?

BTW, the imap problems reported originally in this post have disappeared.
Regarding, increasing "the number of auth daemons".
Pardon me, but can you list the file that needs to be changed, and/or the general process to do this? Thanks.