The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

imap

Discussion in 'General Discussion' started by jackal, Mar 27, 2003.

  1. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Keep getting this error,

    imap failed @ Thu Mar 27 03:33:30 2003. A restart was attempted automagicly.

    I tried to restart from WHM and got this error.

    Any ideas?


    Mar 27 01:41:26 subzero xinetd[15027]: Server imapd is not executable [line=8] Mar 27 01:50:03 subzero xinetd[16638]: Server imapd is not executable [line=8] Mar 27 01:58:40 subzero xinetd[17378]: Server imapd is not executable [line=8] Mar 27 02:07:18 subzero xinetd[18152]: Server imapd is not executable [line=8] Mar 27 02:15:55 subzero xinetd[18763]: Server imapd is not executable [line=8] Mar 27 02:24:33 subzero xinetd[19417]: Server imapd is not executable [line=8] Mar 27 02:33:13 subzero xinetd[20112]: Server imapd is not executable [line=8] Mar 27 02:41:48 subzero xinetd[21301]: Server imapd is not executable [line=8] Mar 27 02:50:26 subzero xinetd[22294]: Server imapd is not executable [line=8] Mar 27 02:59:03 subzero xinetd[22835]: Server imapd is not executable [line=8] Mar 27 03:07:39 subzero xinetd[23352]: Server imapd is not executable [line=8] Mar 27 03:16:16 subzero xinetd[23624]: Server imapd is not executable [line=8] Mar 27 03:24:54 subzero xinetd[23970]: Server imapd is not executable [line=8] Mar 27 03:33:31 subzero xinetd[24292]: Server imapd is not executable [line=8] Mar 27 03:39:21 subzero xinetd[24822]: Server imapd is not executable [line=8] imap has failed, please contact the sysadmin.
     
  2. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    We had no problem with this at any time until the update last nite. Now since the update we have gotten this error in the email around 50 times. What in the update last nite changed with imap and the setup?
     
  3. orangechicken

    orangechicken Member

    Joined:
    Dec 4, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    This seems to concur with when my problems started too. IMAP is just broken in the latest CPanel updates.

    Any ideas why yet?
     
  4. ladymacbeth

    ladymacbeth Member

    Joined:
    Nov 17, 2002
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    imap service

    Hello,

    The configuration file for Imap in the server is /etc/xinetd.d/imap. First check out the path for imap in the server by the command

    whereis imap

    Then you need to edit the file /etc/xinetd.d/imap and give this path for the entry 'server' in it.

    now restart xinetd by the commands

    /etc/rc.d/init.d/xinetd stop

    /etc/rc.d/init.d/xinetd start

    This should make the imap server work fine.

    Regards
    Reeshma.

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  5. LS_Drew

    LS_Drew Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    187
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    None of that stuff works.

    Still broken. Same symptoms as above. :(

    cPanel.net Support Ticket Number:
     
  6. paralard

    paralard Well-Known Member

    Joined:
    Mar 2, 2003
    Messages:
    114
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Austin Texas
    Same here...............???????

    cPanel.net Support Ticket Number:
     
  7. Sergio

    Sergio Registered

    Joined:
    Jun 2, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I've reinstalled imap (you can do it from rpm) it's working but I can't log to any mail account created by CPanel.

    cPanel.net Support Ticket Number:
     
  8. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    Try to
    pico /etc/xinetd.d/imap
    Change the line server = imapd into
    server = /usr/sbin/imapd

    cPanel.net Support Ticket Number:
     
  9. asmar

    asmar Well-Known Member

    Joined:
    Jul 16, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Solved


    That solved the problem for me.

    I can log in and send emails (only through the main account) but I am taking the following error on SquirrelMail

    ERROR:
    ERROR : Could not complete request.
    Query: SUBSCRIBE "INBOX.Trash"
    Reason Given: SUBSCRIBE failed: Already subscribed to mailbox INBOX.Trash

    The above happened only for the main account.

    All the other accounts can't log in,
    I am getting the following error:
    Unknown user or password incorrect

    Any suggestions?

    Many thanks
     
    #9 asmar, Jul 16, 2004
    Last edited: Jul 16, 2004
  10. jrehmer

    jrehmer Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Denver, CO
    Make sure you are using cpanel's rpm for IMAPD and not RedHats otherwise they will NOT work.
     
  11. kokoman

    kokoman Active Member

    Joined:
    Nov 28, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    BA, Argentina
    I was having the same problem and it was due to the missing file /etc/protocols
     
  12. vivpa

    vivpa Registered

    Joined:
    Nov 16, 2002
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I got this problem after running rpmup and imap was upgraded. The webmail programs don't like other versions of imap other than the one from cpanel. The following, coutesy of Duncan, fixed the problem for me:

    Simply copy the CPanel imapd over the system version and restart the xinetd, which will fix the issue:

    cp -f /usr/local/cpanel/3rdparty/bin/imapd /usr/sbin/imapd
    /etc/rc.d/init.d/xinetd restart
     
  13. nmushik

    nmushik Registered

    Joined:
    May 21, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    None of these fixes worked?! Any other ideas?
     
  14. X-ile

    X-ile Registered

    Joined:
    Aug 13, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Yeah, we need a fix, we get a email every 9 minutes saying imap has failed. If anyone had any idea's please speak up!
     
  15. fuzzymonkey

    fuzzymonkey Well-Known Member

    Joined:
    Jun 11, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Perfect! Thanks!
     
  16. katz_global

    katz_global Well-Known Member
    PartnerNOC

    Joined:
    Oct 18, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hosting from: Panama, Hong Kong, Singapore, Malays
    thx vivpa.

    very helpful.
     
Loading...

Share This Page