jackal

Well-Known Member
PartnerNOC
Feb 23, 2002
707
0
316
Keep getting this error,

imap failed @ Thu Mar 27 03:33:30 2003. A restart was attempted automagicly.

I tried to restart from WHM and got this error.

Any ideas?


Mar 27 01:41:26 subzero xinetd[15027]: Server imapd is not executable [line=8] Mar 27 01:50:03 subzero xinetd[16638]: Server imapd is not executable [line=8] Mar 27 01:58:40 subzero xinetd[17378]: Server imapd is not executable [line=8] Mar 27 02:07:18 subzero xinetd[18152]: Server imapd is not executable [line=8] Mar 27 02:15:55 subzero xinetd[18763]: Server imapd is not executable [line=8] Mar 27 02:24:33 subzero xinetd[19417]: Server imapd is not executable [line=8] Mar 27 02:33:13 subzero xinetd[20112]: Server imapd is not executable [line=8] Mar 27 02:41:48 subzero xinetd[21301]: Server imapd is not executable [line=8] Mar 27 02:50:26 subzero xinetd[22294]: Server imapd is not executable [line=8] Mar 27 02:59:03 subzero xinetd[22835]: Server imapd is not executable [line=8] Mar 27 03:07:39 subzero xinetd[23352]: Server imapd is not executable [line=8] Mar 27 03:16:16 subzero xinetd[23624]: Server imapd is not executable [line=8] Mar 27 03:24:54 subzero xinetd[23970]: Server imapd is not executable [line=8] Mar 27 03:33:31 subzero xinetd[24292]: Server imapd is not executable [line=8] Mar 27 03:39:21 subzero xinetd[24822]: Server imapd is not executable [line=8] imap has failed, please contact the sysadmin.
 

jackal

Well-Known Member
PartnerNOC
Feb 23, 2002
707
0
316
We had no problem with this at any time until the update last nite. Now since the update we have gotten this error in the email around 50 times. What in the update last nite changed with imap and the setup?
 

orangechicken

Member
Dec 4, 2002
10
0
151
This seems to concur with when my problems started too. IMAP is just broken in the latest CPanel updates.

Any ideas why yet?
 

ladymacbeth

Member
Nov 17, 2002
15
0
151
India
imap service

Hello,

The configuration file for Imap in the server is /etc/xinetd.d/imap. First check out the path for imap in the server by the command

whereis imap

Then you need to edit the file /etc/xinetd.d/imap and give this path for the entry 'server' in it.

now restart xinetd by the commands

/etc/rc.d/init.d/xinetd stop

/etc/rc.d/init.d/xinetd start

This should make the imap server work fine.

Regards
Reeshma.

cPanel.net Support Ticket Number:

cPanel.net Support Ticket Number:
 

LS_Drew

Well-Known Member
Feb 20, 2003
187
0
166
Hello,

None of that stuff works.

Still broken. Same symptoms as above. :(

cPanel.net Support Ticket Number:
 

Sergio

Registered
Jun 2, 2003
2
0
151
I've reinstalled imap (you can do it from rpm) it's working but I can't log to any mail account created by CPanel.

cPanel.net Support Ticket Number:
 

cyon

Well-Known Member
PartnerNOC
Jan 15, 2003
314
0
241
Try to
pico /etc/xinetd.d/imap
Change the line server = imapd into
server = /usr/sbin/imapd

cPanel.net Support Ticket Number:
 

asmar

Well-Known Member
Jul 16, 2004
135
0
166
Solved

cyon said:
Try to
pico /etc/xinetd.d/imap
Change the line server = imapd into
server = /usr/sbin/imapd

cPanel.net Support Ticket Number:

That solved the problem for me.

I can log in and send emails (only through the main account) but I am taking the following error on SquirrelMail

ERROR:
ERROR : Could not complete request.
Query: SUBSCRIBE "INBOX.Trash"
Reason Given: SUBSCRIBE failed: Already subscribed to mailbox INBOX.Trash

The above happened only for the main account.

All the other accounts can't log in,
I am getting the following error:
Unknown user or password incorrect

Any suggestions?

Many thanks
 
Last edited:

jrehmer

Well-Known Member
Apr 10, 2003
286
0
166
Denver, CO
asmar said:
That solved the problem for me.

I can log in and send emails (only through the main account) but I am taking the following error on SquirrelMail

ERROR:
ERROR : Could not complete request.
Query: SUBSCRIBE "INBOX.Trash"
Reason Given: SUBSCRIBE failed: Already subscribed to mailbox INBOX.Trash

The above happened only for the main account.

All the other accounts can't log in,
I am getting the following error:
Unknown user or password incorrect

Any suggestions?

Many thanks
Make sure you are using cpanel's rpm for IMAPD and not RedHats otherwise they will NOT work.
 

kokoman

Active Member
Nov 28, 2002
27
0
151
BA, Argentina
jrehmer said:
Make sure you are using cpanel's rpm for IMAPD and not RedHats otherwise they will NOT work.
I was having the same problem and it was due to the missing file /etc/protocols
 

vivpa

Registered
Nov 16, 2002
2
0
151
I got this problem after running rpmup and imap was upgraded. The webmail programs don't like other versions of imap other than the one from cpanel. The following, coutesy of Duncan, fixed the problem for me:

Simply copy the CPanel imapd over the system version and restart the xinetd, which will fix the issue:

cp -f /usr/local/cpanel/3rdparty/bin/imapd /usr/sbin/imapd
/etc/rc.d/init.d/xinetd restart
 

X-ile

Registered
Aug 13, 2004
2
0
151
Yeah, we need a fix, we get a email every 9 minutes saying imap has failed. If anyone had any idea's please speak up!
 

fuzzymonkey

Well-Known Member
Jun 11, 2004
61
0
156
vivpa said:
Simply copy the CPanel imapd over the system version and restart the xinetd, which will fix the issue:

cp -f /usr/local/cpanel/3rdparty/bin/imapd /usr/sbin/imapd
/etc/rc.d/init.d/xinetd restart
Perfect! Thanks!