The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

*IMPORTANT* Tomcat JSP 4.0.3

Discussion in 'General Discussion' started by Diatone, May 4, 2003.

  1. Diatone

    Diatone Well-Known Member

    Joined:
    Aug 22, 2001
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Ok, I've been looking around these forums alot. It seems alot of us need a Tomcat 4.0.3 Build from layer 1. Due to Nick, for some odd reason releasing 4.1, which does not work correctly with apache 1.3, which 99% of us are using. Although no one ever provides a valid link to a tar of this build.

    I know one of you reading this has to have it. Please, take the time, upload it to a web accessible directory, and provide a link. I am sure alot of people on here would be very greatfull, I know I would be.

    Thank you.
     
  2. Alarion

    Alarion Member

    Joined:
    Sep 3, 2001
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    I have the tomcat 4 tar working fine. I had to modify it some to work properly, but it works.

    I used mod_jk instead of mod_jk2 as it's MUCH easier to setup private instances of tomcat.

    What are you having problems with? I can try and offer some help.
     
  3. Diatone

    Diatone Well-Known Member

    Joined:
    Aug 22, 2001
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    index.jsp files dont work correctly, servlets dont work correctly. How do I go about using mod_jk instead of mod_jk2? Is it included in the build somewhere, anything I need to change in httpd.conf?

    Thanks for your help. It is greatly appreciated.
     
  4. mr_hack

    mr_hack Member

    Joined:
    Dec 8, 2001
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I have problem with tomcat-4.0.3 too. I have apache 1.3.x, and offen it was down, chkservd not corretly restarted apache. I think that this problem in setup Tomcat + Apache1.3. Please tell me, that i must do.
     
  5. RisingHost

    RisingHost Member

    Joined:
    Feb 9, 2003
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
  6. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    How is 4.1.12 'MUCH' easier? I'm curious to know what you mean by that.

    Jaz
     
  7. mr_hack

    mr_hack Member

    Joined:
    Dec 8, 2001
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I have follow error in apache error_log:

    [warn] [csd] filedescriptor (1027) larger than FD_SETSIZE (1024) found, you probably need to rebuild Apac
    he with a larger FD_SETSIZE

    How fixed it?
     
  8. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Run easyapache.
     
  9. Diatone

    Diatone Well-Known Member

    Joined:
    Aug 22, 2001
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you for the link!!!

    My savior
     
  10. mr_hack

    mr_hack Member

    Joined:
    Dec 8, 2001
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I did it, but nothing. If i'm turn off modul of tomcat, apache forking corretly, but if i'm loaded tomcat, i have this error. How fixed it?
     
  11. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    When you ran easyapache, did you select option 6? and select increase fd_size?
     
  12. mr_hack

    mr_hack Member

    Joined:
    Dec 8, 2001
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    No, but i'm try do it. Thank you.
     
  13. mr_hack

    mr_hack Member

    Joined:
    Dec 8, 2001
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hmm, and where documentation for Advansed apache setup? :)
    Do you have it?
     
  14. cybernet

    cybernet Member

    Joined:
    May 5, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Any mods going to answer this question.. ?

    Where is the documentation about using ./easyapache with options.. ?

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page