Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

ImportError: No module named korean / How do you disable mailman?

Discussion in 'E-mail Discussion' started by Vatoloco, Nov 28, 2007.

  1. Vatoloco

    Vatoloco Well-Known Member

    Joined:
    Jun 21, 2004
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    166
    I'm not using a mailing list on my server and want to completely disable mailman. I unchecked Mailman under Tweak Settings in WHM but I'm getting a bunch of error messages e-mailed to me that look related to mailman:

    Code:
    Cron <mailman@myhost> /usr/bin/python2.4 -S /usr/local/cpanel/3rdparty/mailman/cron/senddigests
    
    Traceback (most recent call last):
      File "/usr/local/cpanel/3rdparty/mailman/cron/senddigests", line 36, in ?
        import paths
      File "/usr/local/cpanel/3rdparty/mailman/cron/paths.py", line 60, in ?
        import korean
    ImportError: No module named korean
    Code:
    Cron <mailman@myhost> /usr/bin/python2.4 -S /usr/local/cpanel/3rdparty/mailman/cron/disabled
    
    Traceback (most recent call last):
      File "/usr/local/cpanel/3rdparty/mailman/cron/disabled", line 67, in ?
        import paths
      File "/usr/local/cpanel/3rdparty/mailman/cron/paths.py", line 60, in ?
        import korean
    ImportError: No module named korean
    Code:
    Cron <mailman@myhost> /usr/bin/python2.4 -S /usr/local/cpanel/3rdparty/mailman/cron/checkdbs
    
    Traceback (most recent call last):
      File "/usr/local/cpanel/3rdparty/mailman/cron/checkdbs", line 34, in ?
        import paths
      File "/usr/local/cpanel/3rdparty/mailman/cron/paths.py", line 60, in ?
        import korean
    ImportError: No module named korean
    Code:
    Cron <mailman@myhost> /usr/bin/python2.4 -S /usr/local/cpanel/3rdparty/mailman/cron/nightly_gzi
    
    Traceback (most recent call last):
      File "/usr/local/cpanel/3rdparty/mailman/cron/nightly_gzip", line 52, in ?
        import paths
      File "/usr/local/cpanel/3rdparty/mailman/cron/paths.py", line 60, in ?
        import korean
    ImportError: No module named korean

    Does anyone know how I would stop those errors and completely disable mailmain?
     
  2. Vatoloco

    Vatoloco Well-Known Member

    Joined:
    Jun 21, 2004
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    166
    I'm still not sure why I was getting that error in the first place, but I think removing mailman and its cron entries will solve my problem. I don't use mailing lists so I shouldn't have any need for it. Here's the guide I found to do that:

    http://wiki.asmallorange.com/HOWTODisableMailman

     
  3. Vatoloco

    Vatoloco Well-Known Member

    Joined:
    Jun 21, 2004
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    166
    No luck

    I can't seem to keep mailman disabled. cPanel did an automatic update last night and the mailman lines in httpd.conf came back plus all the mailman crontab entries were restored so I started getting those ImportError e-mails again.

    Is there any way to stop upcp from restoring all the mailman settings?
     
  4. sabarishks

    sabarishks Active Member

    Joined:
    Jun 29, 2007
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    56
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. HostingH

    HostingH Well-Known Member

    Joined:
    Jan 13, 2008
    Messages:
    126
    Likes Received:
    18
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    mailman error

    Yes , Its solved my problem. :))


    :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. grayloon

    grayloon Well-Known Member

    Joined:
    Oct 31, 2007
    Messages:
    113
    Likes Received:
    3
    Trophy Points:
    68
    Location:
    Evansville, IN
    cPanel Access Level:
    Root Administrator
    Twitter:
    My security scanning service, McAfee Secure, is showing Mailman as being vulnerable. Here's their explanation:
    I unchecked Mailman in WHM > Server Configuration > Tweak Settings, but it still comes up via the web: http://domain.com/mailman/admin/mailman. How can I turn it off permanently???
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice