SysSachin

Well-Known Member
Aug 23, 2015
604
48
28
India
cPanel Access Level
Root Administrator
Twitter
Hi,
You need to contact to your web-hosting provider for this as you have only cPanel Access Level. Or you can upload .sql file through file manager or FTP and ask your hosting provide to restore it through command line.
 

cPLevey

Technical Analyst Manager
Staff member
Dec 3, 2015
44
8
133
Houston, TX
cPanel Access Level
Root Administrator
Hey @saranyabasu

If you have root level (WHM) access. Check your current settings in WHM's (Home »Server Configuration »Tweak Settings) [ PHP ]. You will want to make sure the following setting is adjusted to be larger than the file size you are trying to upload:

"cPanel PHP max upload size (Minimum: 50; Maximum: 2,047)"
 

vikins

Well-Known Member
Oct 3, 2006
127
1
168
Hey @saranyabasu

If you have root level (WHM) access. Check your current settings in WHM's (Home »Server Configuration »Tweak Settings) [ PHP ]. You will want to make sure the following setting is adjusted to be larger than the file size you are trying to upload:

"cPanel PHP max upload size (Minimum: 50; Maximum: 2,047)"
This updates the phpMyAdmin that is within WHM. But it does not change the end-user file import size if the end-user clicks on the phpMyAdmin icon in their own cPanel. That is still at 50 for some reason. Changing the settings about DOES affect the phpMyAdmin upload limits for the WHM "version" of phpMyAdmin.

How can the end-user limits be changed? Thank you.
 

SysSachin

Well-Known Member
Aug 23, 2015
604
48
28
India
cPanel Access Level
Root Administrator
Twitter
Hello,

Try to change "cPanel PHP Max POST size" also in WHM.
Step : Go to Tweak settings, find the "cPanel PHP Max POST size" change it according to your needs. Save changes
 

vikins

Well-Known Member
Oct 3, 2006
127
1
168
Hello,

Try to change "cPanel PHP Max POST size" also in WHM.
Step : Go to Tweak settings, find the "cPanel PHP Max POST size" change it according to your needs. Save changes
Thank you. I did do that already as well and it does change the upload size limit for phpMyAdmin that is located within WHM, but not phpMyAdmin for end user cPanel. Still looking for a solution.
 

SysSachin

Well-Known Member
Aug 23, 2015
604
48
28
India
cPanel Access Level
Root Administrator
Twitter
Try to increase cPanel PHP max POST size and cPanel PHP max upload size on your server through WHM »Server Configuration »Tweak Settings
 

vikins

Well-Known Member
Oct 3, 2006
127
1
168
Try to increase cPanel PHP max POST size and cPanel PHP max upload size on your server through WHM »Server Configuration »Tweak Settings
Thank you. This has been suggested and I have tried this, changing both to 200 MBs. This DOES change the upload limit for phpMyAdmin initiated from within WHM. But it does not change the 50 MB upload limit for phpMyAdmin initiated from end-user cPanel's. Any suggestions for getting that changed?
 

vikins

Well-Known Member
Oct 3, 2006
127
1
168
You should upload the sql file to the server and restore it via the command line. Trying to upload and restore a large DB from your browser is a bad idea, IMO.
A logical suggestion. But this is a case where a 3rd party needs to upload and giving them shell access isn't my first choice. It is basically a one time upload, so I may just have them send me the file.

But nonetheless, I'd still like to know how to increase the end-user phpMyAdmin file upload limit?
 

vikins

Well-Known Member
Oct 3, 2006
127
1
168
For some reason I had to run this command to get the new php settings to propagate to end user cPanel / phpMyAdmin:

Restart cPanel service:
/bin/systemctl restart cpanel.service

I wouldn't think this would be necessary, but apparently it is. Seems like a bug.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
For some reason I had to run this command to get the new php settings to propagate to end user cPanel / phpMyAdmin:

Restart cPanel service:
/bin/systemctl restart cpanel.service

I wouldn't think this would be necessary, but apparently it is. Seems like a bug.
Hello,

I'm unable to reproduce this issue. After changing the "cPanel PHP max POST size" value in "WHM >> Tweak Settings", I browsed to phpMyAdmin within cPanel and it correctly reflected the new value. Please let us know the specific version of cPanel installed on this system:

Code:
cat /usr/local/cpanel/version
Also, do you notice any error messages output to /usr/local/cpanel/logs/error_log when saving the changes in "WHM >> Tweak Settings"?

Thank you.
 

vikins

Well-Known Member
Oct 3, 2006
127
1
168
Running 11.60.0.26 currently.

Yep, just confirmed it. I changed the settings in tweak settings and it changed the upload limit for the WHM phpMyAdmin but not end user cPanel phpMyAdmin. Here are the log entries when saving the update in tweak settings (I changed the server name).

/usr/local/cpanel/logs/error_log:

[2016-12-14 11:17:25 -0500] info [build_apache_conf] Missing owner for domain server1.servername.com, force lookup to root
Can't call method "internal_error" on unblessed reference at cpsrvd.pl line 706 during global destruction.
Can't call method "internal_error" on unblessed reference at cpsrvd.pl line 706 during global destruction.
[2016-12-14 11:17:27 -0500] info [cpsrvd] Restarting cpsrvd daemon process 7204 via /usr/local/cpanel/cpsrvd
Can't call method "internal_error" on unblessed reference at cpsrvd.pl line 706 during global destruction.
==> cpsrvd 11.60.0.26 started
==> cpsrvd: loading security policy....Done
==> cpsrvd: Setting up SSL support ... Done
==> cpsrvd: transferred port bindings
==> cpsrvd: bound to ports
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Yep, just confirmed it. I changed the settings in tweak settings and it changed the upload limit for the WHM phpMyAdmin but not end user cPanel phpMyAdmin.
Hello,

Are you closing phpMyAdmin to end the session, and then reopening it? Note that you won't see the change until you close the browser tab/window and then open phpMyAdmin again from within cPanel.

Thank you.
 

vikins

Well-Known Member
Oct 3, 2006
127
1
168
Hello,

Are you closing phpMyAdmin to end the session, and then reopening it? Note that you won't see the change until you close the browser tab/window and then open phpMyAdmin again from within cPanel.

Thank you.
No, not closing it, just hitting refresh in the browser. WHM version updates with a refresh, cPanel version does not. Doesn't matter if I log out or not. A completely different person from another country didn't see it update either, so I don't think that is the issue.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello @vikins,

Were you able to open a support ticket to allow us to take a closer look? If so, could you post the ticket number or let us know the outcome?

Thanks!
 

vikins

Well-Known Member
Oct 3, 2006
127
1
168
Hello @vikins,

Were you able to open a support ticket to allow us to take a closer look? If so, could you post the ticket number or let us know the outcome?

Thanks!
Not yet. Wish the process was a little more streamlined. Always feels like a chore to open one. Reduce the friction for opening a ticket and I think people would be more willing to spend the time to submit and document issues.