The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

inbox.lock fix #983247 (NEW content inside)

Discussion in 'General Discussion' started by randomuser, Nov 1, 2005.

  1. randomuser

    randomuser Well-Known Member

    Jun 25, 2005
    Likes Received:
    Trophy Points:
    I am posting this thread in hopes that it saves someone the time of trying all these other fixes and whatnot that don't work, or potentially run the risk of corrupting a user's mailbox.

    We recently had this stupid, annoying inbox.lock issue with a customer. After trying every fix listed in this forum and getting nowhere (aside from "upgrading" to "run at your own risk" software, the customer was able to resolve the issue on his own.

    Problem: customer was checking their email every 60 seconds using "Entourage" for MacOS.

    Solution: customer switched to Apple Mail, problem solved.

    Conclusion and pure speculation: when set to check for new mail every 60 seconds, Entourage is actually producing more activity with the mailserver than expected (ie: it does not perform as you'd think). This was reflected in the logs, showing numerous accesses within a 60 second timeframe. As such, the locks were .constantly. being created and removed, interfering with other mail activity. If I had a MAC and Entourage, I'd sniff the traffic myself while monitoring the directory where the lock file is created and removed, but, I don't. Glad to put this issue to rest, and I hope it helps someone else along the way.

    edit: now the user is saying that this has solved for now anyway. It's entirely possible the issue will crop up again. Who knows with this one. Sorry for any false hope =]
    #1 randomuser, Nov 1, 2005
    Last edited: Nov 1, 2005
  2. chirpy

    chirpy Well-Known Member

    Jun 15, 2002
    Likes Received:
    Trophy Points:
    Go on, have a guess
    I presume you're using cppop? If so, then upgrading to the new maildir system using courier-imap/courier-pop may resolve the issue, though I've seen plenty of problems with Mac users and the Entourage app.

Share This Page