The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

inbox.lock really an headache

Discussion in 'General Discussion' started by david510, Dec 22, 2005.

  1. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Hello Chirpy,

    I saw the solution for inbox.lock from your post. This is not working. Please help me...I have not opened mail box from more than one location.

    --------------
    What you should do is look inside that file (inbox.lock) which will contain a PID. That PID is the cppop process that is (was) looking after that login. You then need to see if it is running:

    ps axf | grep PID

    where PID is the number in the lock file. If there's no cppop process running with that PID, then it's dead and you can delete the inbox.lock file safely.

    If the cppop process for the PID is still running, then you have a choice:

    1. Leave it alone and wait for a timeout (usually 5 minutes)
    2. Kill the PID and then delete the inbox.lock
    ---------------
     
  2. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    You can also run /scripts/mailperm which will delete the inbox lock file. But the big question is why is it a problem? Are you getting email with two clients on the same machine?
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The best solution for issues with inbox.lock is to convert to maildir as this (and courier-imap/pop) doesn't suffer from the problem. You will continue to have locking issues if you stay with cppop (though you could switch to IMAP instead).
     
  4. RizyDeWino

    RizyDeWino Well-Known Member

    Joined:
    Aug 1, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Planet Earth
    This lock is created due to number of reasons when you are downloading your email via pop , one can be due to large emails and secondly it could be due to slow network connectivity. As the mailbox will be in lock state until certain email is completely download.

    You can avoid the time of lock by not checking email too often e.g every minute as it will cause the lock to setup every minute. Setting the send/recienve to five or ten minutes may solve your problem.
     
  5. __arjun__

    __arjun__ Guest

    the best soln is to go for maildir format, but it has some issues with cpanel.
    I think with maildir format, neomail won't work, so some people may complain :-p
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Actually, the main reason on cPanel servers is a locking conflict between exim and cppop, which is why the switch to maildir is the best solution as it removes this conflict.
     
Loading...

Share This Page