Incoming and Outgoing Email does not work after Cpanel Update

rqsweat

Active Member
Mar 25, 2003
42
0
156
New Jersey
HELP! - Incoming and Outgoing Email does not work after Cpanel Update

Hi all,

For the past few weeks,m a few users on SOME, not ALL of my domains have been experiencing problems in Outlook where it would ask them for their username and password repeatedly, even though they were putting in the right passwords, so I was reading through the forums and found that a few people updated CP which fixed.

Well yesterday I ran a /scripts/cpup and now Incoming and Outgoing Email does not work and I cannot figure out why. Neomail, Squirrelmail and Horde was not wodking also but I fixed that with the latest build. I tried downgrading CP but that didnt do anything for Outgoing and Incoming Email. After reading through the forums, I found a few others who were experiening the similar problems...but the methods they used to resolve their issues did not work with me.

I need help. Could you all offer some suggestions to what I can do to get email working for all of my users.

Here's what I've done so far:
- All services are "ok" No failed services
- I've upgraded to the latest edge (now at 52)
- I ran scripts which were suggested throughout these forums including:
/scripts/updatenow
/scripts/eximup --latest
/scripts/mailperm
/etc/init.d/cpanel restart
AND

cd /etc/
chattr -i exim.conf
chattr -i exim.crt
chattr -i exim.key
chattr -i exim.pl
chattr -i eximrejects
chattr -i antivirus.exim
chattr -i localdomains
chattr -i aliases
chattr -i secondarymx
/scripts/exim4
I've rebooted the server, exim, imap, pop3. I even tried sending myself an email locally but still nothing. So I ran a trace on my email with "exim -d2 -bt [email protected]" and received the following message.

exim: malformed debug_selector setting: + or - expected but found "2"
Any help would be greatly appreciated!
 
Last edited:

lankyb

Well-Known Member
Sep 21, 2004
99
0
166
Peterborough, UK
Have you tried this. Its a complete forced update, which generally solves problems like this:

Code:
/scripts/upcp --force
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
31
473
Go on, have a guess
Another idea is to make sure that you don't have any spurious exim directives by using:

/scripts/reseteximtodefaults
 

rqsweat

Active Member
Mar 25, 2003
42
0
156
New Jersey
I tried both and still "no go". I tried sending myself a test message locally and also to another server but it didnt work. "exim -d2 -bt [email protected]" also yielded the same results:

exim: malformed debug_selector setting: + or - expected but found "2"

I also rebooted after completing the above tasks.

Any other ideas?
 

jackal

Well-Known Member
PartnerNOC
Feb 23, 2002
707
0
316
Go to ssh as root and run this command
tail -f /var/log/exim_mainlog

tell us what you see there.
 

rqsweat

Active Member
Mar 25, 2003
42
0
156
New Jersey
2005-07-03 20:39:39 1DpF0B-0001F6-Dy <= [email protected] H=(68-186-138-
87.dhcp.jcsn.tn.charter.com) [68.186.138.87] P=smtp S=3394 id=MRZWHHAWIRDUUNDKJP
[email protected]
2005-07-03 20:39:41 1DpF0E-0001F7-Hy <= [email protected] H=(sympatico.ca) [
63.13.192.148] P=smtp S=1192 [email protected]
2005-07-03 20:40:46 1DpF1I-0001FV-75 <= [email protected] H=(66.98.14
4.231) [211.115.220.63] P=smtp S=2049 [email protected]
2005-07-03 20:40:52 1DpF1O-0001FV-2J <= [email protected] H=(66.98.144.231)
[211.115.220.63] P=smtp S=2518 [email protected]
2005-07-03 20:40:56 1DpF1S-0001FV-07 <= [email protected] H=(66.98.144.2
31) [211.115.220.63] P=smtp S=3012 [email protected]
2005-07-03 20:41:01 1DpF1X-0001FV-D1 <= [email protected] H=(66.9
8.144.231) [211.115.220.63] P=smtp S=2612 [email protected]
om
2005-07-03 20:42:20 1DpF2e-0001Fw-Dg <= [email protected] H=(66.98.144.231) [2
00.217.77.190] P=smtp S=2009 [email protected]
2005-07-03 20:44:10 1DpF4Z-0001GD-SP <= [email protected] H=(surrealestat
e.com) [219.131.74.45] P=smtp S=1607 [email protected]
2005-07-03 20:44:11 1DpF4Z-0001GB-JA <= [email protected] H=(66.98.144.231) [
61.76.186.158] P=smtp S=1079 [email protected]
.com
2005-07-03 20:44:15 1DpF4c-0001GC-SO <= [email protected] H=(forza-ju
ventus.com) [219.131.74.45] P=smtp S=1580 [email protected]
2005-07-03 20:44:24 1DpF4i-0001GE-Kr <= [email protected] H=(66.98.144.8) [61.85.33.93] P=smtp S=20605 [email protected]
2005-07-03 20:44:48 1DpF59-0001GG-N1 <= [email protected] H=(66.98.144.231) [61.83.79.13] P=smtp S=1086 [email protected]
 

jackal

Well-Known Member
PartnerNOC
Feb 23, 2002
707
0
316
Now with that open and while you are watching it send a email to someone on that server from a outside source. Then send someone a email from that server to a outside soruce and watch what happens each time and note it here.
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
31
473
Go on, have a guess
OK, now you need to get the whole transaction for one of those emails:

grep 1DpFJk-00021B-K8 /var/log/exim_mainlog

and post that here :)
 

internetfab

Well-Known Member
PartnerNOC
Feb 20, 2003
335
0
166
Gothenburg, Sweden
cPanel Access Level
DataCenter Provider
We have the exact same error on one of our servers since update.

Have now tried Edge, Release and Stable - no go.

Also tried:
/scripts/updatenow
/scripts/eximup --latest
/scripts/mailperm
/etc/init.d/cpanel restart

tried:
/scripts/upcp --force

and tried:
/scripts/reseteximtodefaults
 

internetfab

Well-Known Member
PartnerNOC
Feb 20, 2003
335
0
166
Gothenburg, Sweden
cPanel Access Level
DataCenter Provider
Ok Solved my problem.
The passwd files had 640 as permissions and seems to need 644
It was set like this on every account on this server - bad update? Think it was the 28th June..

This should solve it:
chmod 644 /home/*/etc/passwd
chmod 644 /home/*/etc/*/passwd

Hope this helps =)