The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Incoming email being dropped inconsistent

Discussion in 'E-mail Discussions' started by gsabatier, Mar 15, 2005.

  1. gsabatier

    gsabatier Registered

    Joined:
    Mar 14, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I've been looking through the forums and haven't found the answer for this but maybe someone has it...

    My server is

    WHM 10.0.0 cPanel 10.0.0-R146
    Fedora i686 - WHM X v3.1.0

    What is happening is that some incoming email is being dropped and some is getting through. I've sent test messages from gmail.com and found that if there is no attachments or small ones they are delivered instantly but if the attachment is larger, say 1mb. The message seems to disappear.

    I have complaints from customers that messages are being delivered days after being sent from an external email system or getting returned after a few days.

    If I sent a test message to test@testyouremail.com the automatic response never is received. The same test from a gmail.com and yahoo account gets the response message.

    Where do I start with this?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The starting point is your log files (Linux):

    /var/log/exim_mainlog

    You should tail that while testing and look for errors.

    Also:

    1. Make sure that the servers main IP address has an rDNS PTR record setup by the netblock owner, i.e. that the following yields a result:

    dig -x 11.22.33.44

    (where 11.22.33.44 is your main servers IP address)

    2. Make sure that domains are resolving correctly with the information in your /etc/resolv.conf

    3. Are you running any add-on apps such as the exiscan patch, MailScanner or the clamavconnector? If the latter (clamavconnector) try removing it.

    4. Do you have WHM > Exim Configuration Editor > Always set the Sender: header when the sender is changed from the actual sender > checked? If so, uncheck it as this is known to cause problems for some people.

    5. Have you tried resetting your exim configuration back to defaults:

    /scripts/reseteximtodefaults
     
Loading...

Share This Page