Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Incoming email messages hung, then flushed at once day(s) after being sent

Discussion in 'E-mail Discussion' started by joshncsu, Jan 2, 2013.

  1. joshncsu

    joshncsu Registered

    Joined:
    Mar 23, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    So this has been going on for a few months, and as far as I know, it happens with 1 email address that many clients send messages to (support). Emails that are sent TO the mail hosted on the cpanel server are being accepted ("Message Accepted" in cpanel Mail Delivery Reports) and logged (/var/log/exim_mainlog, no errors) almost immediately, but they don't show up in the recipient mailbox right away. In some cases, many messages get hung up for days and then all of a sudden they are all flushed and received. I hesitate to use the word "queued" because none of the messages are in the exim queue (exim -bp) nor the cpanel Mail Queue (which may use exim for all I know?), but otherwise it does feel like they are queued somewhere.

    The email server has relatively low traffic, so it's not a bandwidth issue. I don't think it's a DNS issue because the email and DNS has been the same for years and hosted at the same place. Any help to debug this problem will be greatly appreciated. Our support system runs on this email address, and it not working is bad for us and our clients.

    It may be worth noting that emails sent by exim get received right away.
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,491
    Likes Received:
    1,964
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Re: Incoming email messages hung, then flushed at once day(s) after being s

    Hello :)

    I suggest opening a support ticket so we can reproduce this issue. You can submit a ticket using the following URL

    Submit A Ticket

    Post the ticket number here and we can track the issue.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice